openshift-ansible-bin.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. Summary: OpenShift Ansible Scripts for working with metadata hosts
  2. Name: openshift-ansible-bin
  3. Version: 0.0.18
  4. Release: 1%{?dist}
  5. License: ASL 2.0
  6. URL: https://github.com/openshift/openshift-ansible
  7. Source0: %{name}-%{version}.tar.gz
  8. Requires: python2, openshift-ansible-inventory
  9. BuildRequires: python2-devel
  10. BuildArch: noarch
  11. %description
  12. Scripts to make it nicer when working with hosts that are defined only by metadata.
  13. %prep
  14. %setup -q
  15. %build
  16. %install
  17. mkdir -p %{buildroot}%{_bindir}
  18. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  19. mkdir -p %{buildroot}/etc/bash_completion.d
  20. mkdir -p %{buildroot}/etc/openshift_ansible
  21. cp -p ossh oscp opssh opscp ohi %{buildroot}%{_bindir}
  22. cp -pP openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  23. # Make it so we can load multi_ec2.py as a library.
  24. rm %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.py*
  25. ln -sf /usr/share/ansible/inventory/multi_ec2.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.py
  26. ln -sf /usr/share/ansible/inventory/multi_ec2.pyc %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.pyc
  27. cp -p ossh_bash_completion %{buildroot}/etc/bash_completion.d
  28. cp -p openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  29. %files
  30. %{_bindir}/*
  31. %{python_sitelib}/openshift_ansible/
  32. /etc/bash_completion.d/*
  33. %config(noreplace) /etc/openshift_ansible/
  34. %changelog
  35. * Tue Jun 09 2015 Kenny Woodson <kwoodson@redhat.com> 0.0.18-1
  36. - Implement OpenStack provider (lhuard@amadeus.com)
  37. - * Update defaults and examples to track core concepts guide
  38. (jhonce@redhat.com)
  39. - Issue 119 - Add support for ~/.openshift-ansible (jhonce@redhat.com)
  40. - Infrastructure - Add service action to bin/cluster (jhonce@redhat.com)
  41. * Fri May 15 2015 Thomas Wiest <twiest@redhat.com> 0.0.17-1
  42. - fixed the openshift-ansible-bin build (twiest@redhat.com)
  43. * Fri May 15 2015 Thomas Wiest <twiest@redhat.com> 0.0.14-1
  44. - Command line tools import multi_ec2 as lib (kwoodson@redhat.com)
  45. - Adding cache location for multi ec2 (kwoodson@redhat.com)
  46. * Thu May 07 2015 Thomas Wiest <twiest@redhat.com> 0.0.13-1
  47. - added '-e all' to ohi and fixed pylint errors. (twiest@redhat.com)
  48. * Tue May 05 2015 Thomas Wiest <twiest@redhat.com> 0.0.12-1
  49. - fixed opssh and opscp to allow just environment or just host-type.
  50. (twiest@redhat.com)
  51. * Mon May 04 2015 Thomas Wiest <twiest@redhat.com> 0.0.11-1
  52. - changed opssh to a bash script using ohi to make it easier to maintain, and
  53. to expose all of the pssh features directly. (twiest@redhat.com)
  54. - Added --user option to ohi to pre-pend the username in the hostlist output.
  55. (twiest@redhat.com)
  56. - Added utils.py that contains a normalize_dnsname function good for sorting
  57. dns names to a human readable list. (twiest@redhat.com)
  58. * Thu Apr 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.10-1
  59. - added --list-host-types option to opscp (twiest@redhat.com)
  60. * Thu Apr 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.9-1
  61. - added opscp (twiest@redhat.com)
  62. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.8-1
  63. - fixed bug in opssh where it wouldn't actually run pssh (twiest@redhat.com)
  64. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.7-1
  65. - added the ability to run opssh and ohi on all hosts in an environment, as
  66. well as all hosts of the same host-type regardless of environment
  67. (twiest@redhat.com)
  68. - added ohi (twiest@redhat.com)
  69. * Thu Apr 09 2015 Thomas Wiest <twiest@redhat.com> 0.0.6-1
  70. - fixed bug where opssh would throw an exception if pssh returned a non-zero
  71. exit code (twiest@redhat.com)
  72. * Wed Apr 08 2015 Thomas Wiest <twiest@redhat.com> 0.0.5-1
  73. - fixed the opssh default output behavior to be consistent with pssh. Also
  74. fixed a bug in how directories are named for --outdir and --errdir.
  75. (twiest@redhat.com)
  76. * Tue Mar 31 2015 Thomas Wiest <twiest@redhat.com> 0.0.4-1
  77. - Fixed when tag was missing and added opssh completion (kwoodson@redhat.com)
  78. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.3-1
  79. - created a python package named openshift_ansible (twiest@redhat.com)
  80. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.2-1
  81. - added config file support to opssh, ossh, and oscp (twiest@redhat.com)
  82. * Tue Mar 24 2015 Thomas Wiest <twiest@redhat.com> 0.0.1-1
  83. - new package built with tito