openshift-ansible-bin.spec 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. Summary: OpenShift Ansible Scripts for working with metadata hosts
  2. Name: openshift-ansible-bin
  3. Version: 0.0.8
  4. Release: 1%{?dist}
  5. License: ASL 2.0
  6. URL: https://github.com/openshift/openshift-ansible
  7. Source0: %{name}-%{version}.tar.gz
  8. Requires: python2, openshift-ansible-inventory
  9. BuildRequires: python2-devel
  10. BuildArch: noarch
  11. %description
  12. Scripts to make it nicer when working with hosts that are defined only by metadata.
  13. %prep
  14. %setup -q
  15. %build
  16. %install
  17. mkdir -p %{buildroot}%{_bindir}
  18. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  19. mkdir -p %{buildroot}/etc/bash_completion.d
  20. mkdir -p %{buildroot}/etc/openshift_ansible
  21. cp -p ossh oscp opssh ohi %{buildroot}%{_bindir}
  22. cp -p openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  23. cp -p ossh_bash_completion %{buildroot}/etc/bash_completion.d
  24. cp -p openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  25. %files
  26. %{_bindir}/*
  27. %{python_sitelib}/openshift_ansible/
  28. /etc/bash_completion.d/*
  29. %config(noreplace) /etc/openshift_ansible/
  30. %changelog
  31. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.8-1
  32. - fixed bug in opssh where it wouldn't actually run pssh (twiest@redhat.com)
  33. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.7-1
  34. - added the ability to run opssh and ohi on all hosts in an environment, as
  35. well as all hosts of the same host-type regardless of environment
  36. (twiest@redhat.com)
  37. - added ohi (twiest@redhat.com)
  38. * Thu Apr 09 2015 Thomas Wiest <twiest@redhat.com> 0.0.6-1
  39. - fixed bug where opssh would throw an exception if pssh returned a non-zero
  40. exit code (twiest@redhat.com)
  41. * Wed Apr 08 2015 Thomas Wiest <twiest@redhat.com> 0.0.5-1
  42. - fixed the opssh default output behavior to be consistent with pssh. Also
  43. fixed a bug in how directories are named for --outdir and --errdir.
  44. (twiest@redhat.com)
  45. * Tue Mar 31 2015 Thomas Wiest <twiest@redhat.com> 0.0.4-1
  46. - Fixed when tag was missing and added opssh completion (kwoodson@redhat.com)
  47. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.3-1
  48. - created a python package named openshift_ansible (twiest@redhat.com)
  49. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.2-1
  50. - added config file support to opssh, ossh, and oscp (twiest@redhat.com)
  51. * Tue Mar 24 2015 Thomas Wiest <twiest@redhat.com> 0.0.1-1
  52. - new package built with tito