openshift-ansible.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.7
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible
  15. %description
  16. Openshift and Atomic Enterprise Ansible
  17. This repo contains Ansible code and playbooks
  18. for Openshift and Atomic Enterprise.
  19. %prep
  20. %setup -q
  21. %build
  22. # atomic-openshift-utils install
  23. pushd utils
  24. %{__python} setup.py build
  25. popd
  26. %install
  27. # Base openshift-ansible install
  28. mkdir -p %{buildroot}%{_datadir}/%{name}
  29. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  31. # openshift-ansible-bin install
  32. mkdir -p %{buildroot}%{_bindir}
  33. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  34. mkdir -p %{buildroot}/etc/bash_completion.d
  35. mkdir -p %{buildroot}/etc/openshift_ansible
  36. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  37. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  38. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  39. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  40. # Fix links
  41. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  43. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  44. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  45. # openshift-ansible-docs install
  46. # -docs are currently just %doc, no install needed
  47. # openshift-ansible-inventory install
  48. mkdir -p %{buildroot}/etc/ansible
  49. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  52. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  53. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  54. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  55. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  56. # openshift-ansible-playbooks install
  57. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  58. # openshift-ansible-roles install
  59. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  60. # openshift-ansible-filter-plugins install
  61. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  62. # openshift-ansible-lookup-plugins install
  63. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  64. # atomic-openshift-utils install
  65. pushd utils
  66. %{__python} setup.py install --skip-build --root %{buildroot}
  67. # Remove this line once the name change has happened
  68. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  69. popd
  70. # Base openshift-ansible files
  71. %files
  72. %doc LICENSE.md README*
  73. %dir %{_datadir}/ansible/%{name}
  74. # ----------------------------------------------------------------------------------
  75. # openshift-ansible-bin subpackage
  76. # ----------------------------------------------------------------------------------
  77. %package bin
  78. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  79. Requires: %{name}-inventory
  80. Requires: python2
  81. BuildRequires: python2-devel
  82. BuildArch: noarch
  83. %description bin
  84. Scripts to make it nicer when working with hosts that are defined only by metadata.
  85. %files bin
  86. %{_bindir}/*
  87. %{python_sitelib}/openshift_ansible/
  88. /etc/bash_completion.d/*
  89. %config(noreplace) /etc/openshift_ansible/
  90. # ----------------------------------------------------------------------------------
  91. # openshift-ansible-docs subpackage
  92. # ----------------------------------------------------------------------------------
  93. %package docs
  94. Summary: Openshift and Atomic Enterprise Ansible documents
  95. Requires: %{name}
  96. BuildArch: noarch
  97. %description docs
  98. %{summary}.
  99. %files docs
  100. %doc docs
  101. # ----------------------------------------------------------------------------------
  102. # openshift-ansible-inventory subpackage
  103. # ----------------------------------------------------------------------------------
  104. %package inventory
  105. Summary: Openshift and Atomic Enterprise Ansible Inventories
  106. Requires: python2
  107. BuildArch: noarch
  108. %description inventory
  109. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  110. %files inventory
  111. %config(noreplace) /etc/ansible/*
  112. %dir %{_datadir}/ansible/inventory
  113. %{_datadir}/ansible/inventory/multi_inventory.py*
  114. %package inventory-aws
  115. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  116. Requires: %{name}-inventory
  117. Requires: python-boto
  118. BuildArch: noarch
  119. %description inventory-aws
  120. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  121. %files inventory-aws
  122. %{_datadir}/ansible/inventory/aws/ec2.py*
  123. %package inventory-gce
  124. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  125. Requires: %{name}-inventory
  126. Requires: python-libcloud >= 0.13
  127. BuildArch: noarch
  128. %description inventory-gce
  129. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  130. %files inventory-gce
  131. %{_datadir}/ansible/inventory/gce/gce.py*
  132. # ----------------------------------------------------------------------------------
  133. # openshift-ansible-playbooks subpackage
  134. # ----------------------------------------------------------------------------------
  135. %package playbooks
  136. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  137. Requires: %{name}
  138. BuildArch: noarch
  139. %description playbooks
  140. %{summary}.
  141. %files playbooks
  142. %{_datadir}/ansible/%{name}/playbooks
  143. # ----------------------------------------------------------------------------------
  144. # openshift-ansible-roles subpackage
  145. # ----------------------------------------------------------------------------------
  146. %package roles
  147. Summary: Openshift and Atomic Enterprise Ansible roles
  148. Requires: %{name}
  149. BuildArch: noarch
  150. %description roles
  151. %{summary}.
  152. %files roles
  153. %{_datadir}/ansible/%{name}/roles
  154. # ----------------------------------------------------------------------------------
  155. # openshift-ansible-filter-plugins subpackage
  156. # ----------------------------------------------------------------------------------
  157. %package filter-plugins
  158. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  159. Requires: %{name}
  160. BuildArch: noarch
  161. %description filter-plugins
  162. %{summary}.
  163. %files filter-plugins
  164. %{_datadir}/ansible_plugins/filter_plugins
  165. # ----------------------------------------------------------------------------------
  166. # openshift-ansible-lookup-plugins subpackage
  167. # ----------------------------------------------------------------------------------
  168. %package lookup-plugins
  169. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  170. Requires: %{name}
  171. BuildArch: noarch
  172. %description lookup-plugins
  173. %{summary}.
  174. %files lookup-plugins
  175. %{_datadir}/ansible_plugins/lookup_plugins
  176. # ----------------------------------------------------------------------------------
  177. # atomic-openshift-utils subpackage
  178. # ----------------------------------------------------------------------------------
  179. %package -n atomic-openshift-utils
  180. Summary: Atomic OpenShift Utilities
  181. BuildRequires: python-setuptools
  182. Requires: openshift-ansible-playbooks
  183. Requires: openshift-ansible-roles
  184. Requires: ansible
  185. Requires: python-click
  186. Requires: python-setuptools
  187. Requires: PyYAML
  188. BuildArch: noarch
  189. %description -n atomic-openshift-utils
  190. Atomic OpenShift Utilities includes
  191. - atomic-openshift-installer
  192. - other utilities
  193. %files -n atomic-openshift-utils
  194. %{python_sitelib}/ooinstall*
  195. %{_bindir}/atomic-openshift-installer
  196. %changelog
  197. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  198. - added the %%util in zabbix (mwoodson@redhat.com)
  199. - atomic-openshift-installer: Correct default playbook directory
  200. (smunilla@redhat.com)
  201. - Support for gce (kwoodson@redhat.com)
  202. - fixed a dumb naming mistake (mwoodson@redhat.com)
  203. - added disk tps checks to zabbix (mwoodson@redhat.com)
  204. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  205. - atomic-openshift-installer: Add default openshift-ansible-playbook
  206. (smunilla@redhat.com)
  207. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  208. - ooinstall: Update local install check (smunilla@redhat.com)
  209. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  210. - Moving to Openshift Etcd application (mmahut@redhat.com)
  211. - Add all the possible servicenames to openshift_all_hostnames for masters
  212. (sdodson@redhat.com)
  213. - Adding openshift.node.etcd items (mmahut@redhat.com)
  214. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  215. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  216. - split inventory into subpackages (tdawson@redhat.com)
  217. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  218. warning (mwoodson@redhat.com)
  219. - Rename install_transactions module to openshift_ansible.
  220. (dgoodwin@redhat.com)
  221. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  222. - Add utils subpackage missing dep on openshift-ansible-roles.
  223. (dgoodwin@redhat.com)
  224. - Disable requiretty for only the openshift user (error@ioerror.us)
  225. - Don't require tty to run sudo (error@ioerror.us)
  226. - Attempt to remove the various interfaces left over from an install
  227. (bleanhar@redhat.com)
  228. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  229. - Disable OpenShift features if installing Atomic Enterprise
  230. (jdetiber@redhat.com)
  231. - Use default playbooks if available. (dgoodwin@redhat.com)
  232. - Add uninstall subcommand. (dgoodwin@redhat.com)
  233. - Add subcommands to CLI. (dgoodwin@redhat.com)
  234. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  235. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  236. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  237. dependency (kwoodson@redhat.com)
  238. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  239. (abutcher@redhat.com)
  240. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  241. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  242. - Updating multi_ec2 to support extra_vars and extra_groups
  243. (kwoodson@redhat.com)
  244. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  245. - README_AEP.md: update instructions for creating router and registry
  246. (jlebon@redhat.com)
  247. - README_AEP: Various fixes (walters@verbum.org)
  248. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  249. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  250. - remove debugging pauses (jdetiber@redhat.com)
  251. - make storage plugin dependency installation more flexible
  252. (jdetiber@redhat.com)
  253. - Install storage plugin dependencies (jdetiber@redhat.com)
  254. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  255. - Removing spec files. (kwoodson@redhat.com)
  256. - Updated example (kwoodson@redhat.com)
  257. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  258. (kwoodson@redhat.com)
  259. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  260. (kwoodson@redhat.com)
  261. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  262. (kwoodson@redhat.com)
  263. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  264. (kwoodson@redhat.com)
  265. - Adding tito releasers configuration (bleanhar@redhat.com)
  266. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  267. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  268. (kwoodson@redhat.com)
  269. - Start tracking docker info execution time (jdiaz@redhat.com)
  270. - The uninstall playbook should remove the kubeconfig for non-root installs
  271. (bleanhar@redhat.com)
  272. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  273. - add examples for SDN configuration (jdetiber@redhat.com)
  274. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  275. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  276. - Pylint fixes (abutcher@redhat.com)
  277. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  278. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  279. ansible.spec file (tdawson@redhat.com)
  280. - Fix quotes (spinolacastro@gmail.com)
  281. - Use standard library for version comparison. (abutcher@redhat.com)
  282. - added docker info to the end of docker loop to direct lvm playbook.
  283. (twiest@redhat.com)
  284. - Add missing quotes (spinolacastro@gmail.com)
  285. - Adding Docker Log Options capabilities (epo@jemba.net)
  286. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  287. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  288. - Add proxy client certs to master config. (abutcher@redhat.com)
  289. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  290. - Get default values from openshift_facts (spinolacastro@gmail.com)
  291. - Cleanup (spinolacastro@gmail.com)
  292. - Add missing inventory example (spinolacastro@gmail.com)
  293. - Custom Project Config (spinolacastro@gmail.com)
  294. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  295. - Initial Package