openshift-ansible.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.7
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible
  15. %description
  16. Openshift and Atomic Enterprise Ansible
  17. This repo contains Ansible code and playbooks
  18. for Openshift and Atomic Enterprise.
  19. %prep
  20. %setup -q
  21. %build
  22. # atomic-openshift-utils install
  23. pushd utils
  24. %{__python} setup.py build
  25. popd
  26. %install
  27. # Base openshift-ansible install
  28. mkdir -p %{buildroot}%{_datadir}/%{name}
  29. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  31. # openshift-ansible-bin install
  32. mkdir -p %{buildroot}%{_bindir}
  33. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  34. mkdir -p %{buildroot}/etc/bash_completion.d
  35. mkdir -p %{buildroot}/etc/openshift_ansible
  36. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  37. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  38. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  39. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  40. # Fix links
  41. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  43. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  44. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  45. # openshift-ansible-docs install
  46. # -docs are currently just %doc, no install needed
  47. # openshift-ansible-inventory install
  48. mkdir -p %{buildroot}/etc/ansible
  49. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  52. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  53. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  54. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  55. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  56. # openshift-ansible-playbooks install
  57. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  58. # openshift-ansible-roles install
  59. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  60. # openshift-ansible-filter-plugins install
  61. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  62. # openshift-ansible-lookup-plugins install
  63. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  64. # atomic-openshift-utils install
  65. pushd utils
  66. %{__python} setup.py install --skip-build --root %{buildroot}
  67. # Remove this line once the name change has happened
  68. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  69. mkdir -p %{buildroot}%{_datadir}/atomic-openshift-utils/
  70. cp etc/ansible.cfg %{buildroot}%{_datadir}/atomic-openshift-utils/ansible.cfg
  71. popd
  72. # Base openshift-ansible files
  73. %files
  74. %doc LICENSE.md README*
  75. %dir %{_datadir}/ansible/%{name}
  76. # ----------------------------------------------------------------------------------
  77. # openshift-ansible-bin subpackage
  78. # ----------------------------------------------------------------------------------
  79. %package bin
  80. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  81. Requires: %{name}-inventory
  82. Requires: python2
  83. BuildRequires: python2-devel
  84. BuildArch: noarch
  85. %description bin
  86. Scripts to make it nicer when working with hosts that are defined only by metadata.
  87. %files bin
  88. %{_bindir}/*
  89. %exclude %{_bindir}/atomic-openshift-installer
  90. %{python_sitelib}/openshift_ansible/
  91. /etc/bash_completion.d/*
  92. %config(noreplace) /etc/openshift_ansible/
  93. # ----------------------------------------------------------------------------------
  94. # openshift-ansible-docs subpackage
  95. # ----------------------------------------------------------------------------------
  96. %package docs
  97. Summary: Openshift and Atomic Enterprise Ansible documents
  98. Requires: %{name}
  99. BuildArch: noarch
  100. %description docs
  101. %{summary}.
  102. %files docs
  103. %doc docs
  104. # ----------------------------------------------------------------------------------
  105. # openshift-ansible-inventory subpackage
  106. # ----------------------------------------------------------------------------------
  107. %package inventory
  108. Summary: Openshift and Atomic Enterprise Ansible Inventories
  109. Requires: python2
  110. BuildArch: noarch
  111. %description inventory
  112. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  113. %files inventory
  114. %config(noreplace) /etc/ansible/*
  115. %dir %{_datadir}/ansible/inventory
  116. %{_datadir}/ansible/inventory/multi_inventory.py*
  117. %package inventory-aws
  118. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  119. Requires: %{name}-inventory
  120. Requires: python-boto
  121. BuildArch: noarch
  122. %description inventory-aws
  123. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  124. %files inventory-aws
  125. %{_datadir}/ansible/inventory/aws/ec2.py*
  126. %package inventory-gce
  127. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  128. Requires: %{name}-inventory
  129. Requires: python-libcloud >= 0.13
  130. BuildArch: noarch
  131. %description inventory-gce
  132. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  133. %files inventory-gce
  134. %{_datadir}/ansible/inventory/gce/gce.py*
  135. # ----------------------------------------------------------------------------------
  136. # openshift-ansible-playbooks subpackage
  137. # ----------------------------------------------------------------------------------
  138. %package playbooks
  139. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  140. Requires: %{name}
  141. Requires: %{name}-roles
  142. Requires: %{name}-lookup-plugins
  143. Requires: %{name}-filter-plugins
  144. BuildArch: noarch
  145. %description playbooks
  146. %{summary}.
  147. %files playbooks
  148. %{_datadir}/ansible/%{name}/playbooks
  149. # ----------------------------------------------------------------------------------
  150. # openshift-ansible-roles subpackage
  151. # ----------------------------------------------------------------------------------
  152. %package roles
  153. Summary: Openshift and Atomic Enterprise Ansible roles
  154. Requires: %{name}
  155. Requires: %{name}-lookup-plugins
  156. Requires: %{name}-filter-plugins
  157. BuildArch: noarch
  158. %description roles
  159. %{summary}.
  160. %files roles
  161. %{_datadir}/ansible/%{name}/roles
  162. # ----------------------------------------------------------------------------------
  163. # openshift-ansible-filter-plugins subpackage
  164. # ----------------------------------------------------------------------------------
  165. %package filter-plugins
  166. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  167. Requires: %{name}
  168. BuildArch: noarch
  169. %description filter-plugins
  170. %{summary}.
  171. %files filter-plugins
  172. %{_datadir}/ansible_plugins/filter_plugins
  173. # ----------------------------------------------------------------------------------
  174. # openshift-ansible-lookup-plugins subpackage
  175. # ----------------------------------------------------------------------------------
  176. %package lookup-plugins
  177. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  178. Requires: %{name}
  179. BuildArch: noarch
  180. %description lookup-plugins
  181. %{summary}.
  182. %files lookup-plugins
  183. %{_datadir}/ansible_plugins/lookup_plugins
  184. # ----------------------------------------------------------------------------------
  185. # atomic-openshift-utils subpackage
  186. # ----------------------------------------------------------------------------------
  187. %package -n atomic-openshift-utils
  188. Summary: Atomic OpenShift Utilities
  189. BuildRequires: python-setuptools
  190. Requires: openshift-ansible-playbooks
  191. Requires: openshift-ansible-roles
  192. Requires: ansible
  193. Requires: python-click
  194. Requires: python-setuptools
  195. Requires: PyYAML
  196. BuildArch: noarch
  197. %description -n atomic-openshift-utils
  198. Atomic OpenShift Utilities includes
  199. - atomic-openshift-installer
  200. - other utilities
  201. %files -n atomic-openshift-utils
  202. %{python_sitelib}/ooinstall*
  203. %{_bindir}/atomic-openshift-installer
  204. %{_datadir}/atomic-openshift-utils/ansible.cfg
  205. %changelog
  206. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  207. - added the %%util in zabbix (mwoodson@redhat.com)
  208. - atomic-openshift-installer: Correct default playbook directory
  209. (smunilla@redhat.com)
  210. - Support for gce (kwoodson@redhat.com)
  211. - fixed a dumb naming mistake (mwoodson@redhat.com)
  212. - added disk tps checks to zabbix (mwoodson@redhat.com)
  213. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  214. - atomic-openshift-installer: Add default openshift-ansible-playbook
  215. (smunilla@redhat.com)
  216. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  217. - ooinstall: Update local install check (smunilla@redhat.com)
  218. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  219. - Moving to Openshift Etcd application (mmahut@redhat.com)
  220. - Add all the possible servicenames to openshift_all_hostnames for masters
  221. (sdodson@redhat.com)
  222. - Adding openshift.node.etcd items (mmahut@redhat.com)
  223. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  224. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  225. - split inventory into subpackages (tdawson@redhat.com)
  226. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  227. warning (mwoodson@redhat.com)
  228. - Rename install_transactions module to openshift_ansible.
  229. (dgoodwin@redhat.com)
  230. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  231. - Add utils subpackage missing dep on openshift-ansible-roles.
  232. (dgoodwin@redhat.com)
  233. - Disable requiretty for only the openshift user (error@ioerror.us)
  234. - Don't require tty to run sudo (error@ioerror.us)
  235. - Attempt to remove the various interfaces left over from an install
  236. (bleanhar@redhat.com)
  237. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  238. - Disable OpenShift features if installing Atomic Enterprise
  239. (jdetiber@redhat.com)
  240. - Use default playbooks if available. (dgoodwin@redhat.com)
  241. - Add uninstall subcommand. (dgoodwin@redhat.com)
  242. - Add subcommands to CLI. (dgoodwin@redhat.com)
  243. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  244. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  245. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  246. dependency (kwoodson@redhat.com)
  247. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  248. (abutcher@redhat.com)
  249. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  250. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  251. - Updating multi_ec2 to support extra_vars and extra_groups
  252. (kwoodson@redhat.com)
  253. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  254. - README_AEP.md: update instructions for creating router and registry
  255. (jlebon@redhat.com)
  256. - README_AEP: Various fixes (walters@verbum.org)
  257. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  258. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  259. - remove debugging pauses (jdetiber@redhat.com)
  260. - make storage plugin dependency installation more flexible
  261. (jdetiber@redhat.com)
  262. - Install storage plugin dependencies (jdetiber@redhat.com)
  263. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  264. - Removing spec files. (kwoodson@redhat.com)
  265. - Updated example (kwoodson@redhat.com)
  266. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  267. (kwoodson@redhat.com)
  268. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  269. (kwoodson@redhat.com)
  270. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  271. (kwoodson@redhat.com)
  272. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  273. (kwoodson@redhat.com)
  274. - Adding tito releasers configuration (bleanhar@redhat.com)
  275. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  276. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  277. (kwoodson@redhat.com)
  278. - Start tracking docker info execution time (jdiaz@redhat.com)
  279. - The uninstall playbook should remove the kubeconfig for non-root installs
  280. (bleanhar@redhat.com)
  281. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  282. - add examples for SDN configuration (jdetiber@redhat.com)
  283. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  284. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  285. - Pylint fixes (abutcher@redhat.com)
  286. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  287. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  288. ansible.spec file (tdawson@redhat.com)
  289. - Fix quotes (spinolacastro@gmail.com)
  290. - Use standard library for version comparison. (abutcher@redhat.com)
  291. - added docker info to the end of docker loop to direct lvm playbook.
  292. (twiest@redhat.com)
  293. - Add missing quotes (spinolacastro@gmail.com)
  294. - Adding Docker Log Options capabilities (epo@jemba.net)
  295. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  296. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  297. - Add proxy client certs to master config. (abutcher@redhat.com)
  298. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  299. - Get default values from openshift_facts (spinolacastro@gmail.com)
  300. - Cleanup (spinolacastro@gmail.com)
  301. - Add missing inventory example (spinolacastro@gmail.com)
  302. - Custom Project Config (spinolacastro@gmail.com)
  303. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  304. - Initial Package