openshift-ansible.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.7
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible
  15. %description
  16. Openshift and Atomic Enterprise Ansible
  17. This repo contains Ansible code and playbooks
  18. for Openshift and Atomic Enterprise.
  19. %prep
  20. %setup -q
  21. %build
  22. # atomic-openshift-utils install
  23. pushd utils
  24. %{__python} setup.py build
  25. popd
  26. %install
  27. # Base openshift-ansible install
  28. mkdir -p %{buildroot}%{_datadir}/%{name}
  29. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  31. # openshift-ansible-bin install
  32. mkdir -p %{buildroot}%{_bindir}
  33. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  34. mkdir -p %{buildroot}/etc/bash_completion.d
  35. mkdir -p %{buildroot}/etc/openshift_ansible
  36. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  37. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  38. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  39. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  40. # Fix links
  41. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  43. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  44. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  45. # openshift-ansible-docs install
  46. # -docs are currently just %doc, no install needed
  47. # openshift-ansible-inventory install
  48. mkdir -p %{buildroot}/etc/ansible
  49. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  52. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  53. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  54. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  55. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  56. # openshift-ansible-playbooks install
  57. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  58. # openshift-ansible-roles install
  59. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  60. # openshift-ansible-filter-plugins install
  61. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  62. # openshift-ansible-lookup-plugins install
  63. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  64. # atomic-openshift-utils install
  65. pushd utils
  66. %{__python} setup.py install --skip-build --root %{buildroot}
  67. # Remove this line once the name change has happened
  68. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  69. popd
  70. # Base openshift-ansible files
  71. %files
  72. %doc LICENSE.md README*
  73. %dir %{_datadir}/ansible/%{name}
  74. # ----------------------------------------------------------------------------------
  75. # openshift-ansible-bin subpackage
  76. # ----------------------------------------------------------------------------------
  77. %package bin
  78. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  79. Requires: %{name}-inventory
  80. Requires: python2
  81. BuildRequires: python2-devel
  82. BuildArch: noarch
  83. %description bin
  84. Scripts to make it nicer when working with hosts that are defined only by metadata.
  85. %files bin
  86. %{_bindir}/*
  87. %exclude %{_bindir}/atomic-openshift-installer
  88. %{python_sitelib}/openshift_ansible/
  89. /etc/bash_completion.d/*
  90. %config(noreplace) /etc/openshift_ansible/
  91. # ----------------------------------------------------------------------------------
  92. # openshift-ansible-docs subpackage
  93. # ----------------------------------------------------------------------------------
  94. %package docs
  95. Summary: Openshift and Atomic Enterprise Ansible documents
  96. Requires: %{name}
  97. BuildArch: noarch
  98. %description docs
  99. %{summary}.
  100. %files docs
  101. %doc docs
  102. # ----------------------------------------------------------------------------------
  103. # openshift-ansible-inventory subpackage
  104. # ----------------------------------------------------------------------------------
  105. %package inventory
  106. Summary: Openshift and Atomic Enterprise Ansible Inventories
  107. Requires: python2
  108. BuildArch: noarch
  109. %description inventory
  110. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  111. %files inventory
  112. %config(noreplace) /etc/ansible/*
  113. %dir %{_datadir}/ansible/inventory
  114. %{_datadir}/ansible/inventory/multi_inventory.py*
  115. %package inventory-aws
  116. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  117. Requires: %{name}-inventory
  118. Requires: python-boto
  119. BuildArch: noarch
  120. %description inventory-aws
  121. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  122. %files inventory-aws
  123. %{_datadir}/ansible/inventory/aws/ec2.py*
  124. %package inventory-gce
  125. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  126. Requires: %{name}-inventory
  127. Requires: python-libcloud >= 0.13
  128. BuildArch: noarch
  129. %description inventory-gce
  130. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  131. %files inventory-gce
  132. %{_datadir}/ansible/inventory/gce/gce.py*
  133. # ----------------------------------------------------------------------------------
  134. # openshift-ansible-playbooks subpackage
  135. # ----------------------------------------------------------------------------------
  136. %package playbooks
  137. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  138. Requires: %{name}
  139. Requires: %{name}-roles
  140. Requires: %{name}-lookup-plugins
  141. Requires: %{name}-filter-plugins
  142. BuildArch: noarch
  143. %description playbooks
  144. %{summary}.
  145. %files playbooks
  146. %{_datadir}/ansible/%{name}/playbooks
  147. # ----------------------------------------------------------------------------------
  148. # openshift-ansible-roles subpackage
  149. # ----------------------------------------------------------------------------------
  150. %package roles
  151. Summary: Openshift and Atomic Enterprise Ansible roles
  152. Requires: %{name}
  153. Requires: %{name}-lookup-plugins
  154. Requires: %{name}-filter-plugins
  155. BuildArch: noarch
  156. %description roles
  157. %{summary}.
  158. %files roles
  159. %{_datadir}/ansible/%{name}/roles
  160. # ----------------------------------------------------------------------------------
  161. # openshift-ansible-filter-plugins subpackage
  162. # ----------------------------------------------------------------------------------
  163. %package filter-plugins
  164. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  165. Requires: %{name}
  166. BuildArch: noarch
  167. %description filter-plugins
  168. %{summary}.
  169. %files filter-plugins
  170. %{_datadir}/ansible_plugins/filter_plugins
  171. # ----------------------------------------------------------------------------------
  172. # openshift-ansible-lookup-plugins subpackage
  173. # ----------------------------------------------------------------------------------
  174. %package lookup-plugins
  175. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  176. Requires: %{name}
  177. BuildArch: noarch
  178. %description lookup-plugins
  179. %{summary}.
  180. %files lookup-plugins
  181. %{_datadir}/ansible_plugins/lookup_plugins
  182. # ----------------------------------------------------------------------------------
  183. # atomic-openshift-utils subpackage
  184. # ----------------------------------------------------------------------------------
  185. %package -n atomic-openshift-utils
  186. Summary: Atomic OpenShift Utilities
  187. BuildRequires: python-setuptools
  188. Requires: openshift-ansible-playbooks
  189. Requires: openshift-ansible-roles
  190. Requires: ansible
  191. Requires: python-click
  192. Requires: python-setuptools
  193. Requires: PyYAML
  194. BuildArch: noarch
  195. %description -n atomic-openshift-utils
  196. Atomic OpenShift Utilities includes
  197. - atomic-openshift-installer
  198. - other utilities
  199. %files -n atomic-openshift-utils
  200. %{python_sitelib}/ooinstall*
  201. %{_bindir}/atomic-openshift-installer
  202. %changelog
  203. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  204. - added the %%util in zabbix (mwoodson@redhat.com)
  205. - atomic-openshift-installer: Correct default playbook directory
  206. (smunilla@redhat.com)
  207. - Support for gce (kwoodson@redhat.com)
  208. - fixed a dumb naming mistake (mwoodson@redhat.com)
  209. - added disk tps checks to zabbix (mwoodson@redhat.com)
  210. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  211. - atomic-openshift-installer: Add default openshift-ansible-playbook
  212. (smunilla@redhat.com)
  213. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  214. - ooinstall: Update local install check (smunilla@redhat.com)
  215. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  216. - Moving to Openshift Etcd application (mmahut@redhat.com)
  217. - Add all the possible servicenames to openshift_all_hostnames for masters
  218. (sdodson@redhat.com)
  219. - Adding openshift.node.etcd items (mmahut@redhat.com)
  220. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  221. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  222. - split inventory into subpackages (tdawson@redhat.com)
  223. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  224. warning (mwoodson@redhat.com)
  225. - Rename install_transactions module to openshift_ansible.
  226. (dgoodwin@redhat.com)
  227. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  228. - Add utils subpackage missing dep on openshift-ansible-roles.
  229. (dgoodwin@redhat.com)
  230. - Disable requiretty for only the openshift user (error@ioerror.us)
  231. - Don't require tty to run sudo (error@ioerror.us)
  232. - Attempt to remove the various interfaces left over from an install
  233. (bleanhar@redhat.com)
  234. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  235. - Disable OpenShift features if installing Atomic Enterprise
  236. (jdetiber@redhat.com)
  237. - Use default playbooks if available. (dgoodwin@redhat.com)
  238. - Add uninstall subcommand. (dgoodwin@redhat.com)
  239. - Add subcommands to CLI. (dgoodwin@redhat.com)
  240. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  241. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  242. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  243. dependency (kwoodson@redhat.com)
  244. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  245. (abutcher@redhat.com)
  246. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  247. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  248. - Updating multi_ec2 to support extra_vars and extra_groups
  249. (kwoodson@redhat.com)
  250. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  251. - README_AEP.md: update instructions for creating router and registry
  252. (jlebon@redhat.com)
  253. - README_AEP: Various fixes (walters@verbum.org)
  254. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  255. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  256. - remove debugging pauses (jdetiber@redhat.com)
  257. - make storage plugin dependency installation more flexible
  258. (jdetiber@redhat.com)
  259. - Install storage plugin dependencies (jdetiber@redhat.com)
  260. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  261. - Removing spec files. (kwoodson@redhat.com)
  262. - Updated example (kwoodson@redhat.com)
  263. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  264. (kwoodson@redhat.com)
  265. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  266. (kwoodson@redhat.com)
  267. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  268. (kwoodson@redhat.com)
  269. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  270. (kwoodson@redhat.com)
  271. - Adding tito releasers configuration (bleanhar@redhat.com)
  272. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  273. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  274. (kwoodson@redhat.com)
  275. - Start tracking docker info execution time (jdiaz@redhat.com)
  276. - The uninstall playbook should remove the kubeconfig for non-root installs
  277. (bleanhar@redhat.com)
  278. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  279. - add examples for SDN configuration (jdetiber@redhat.com)
  280. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  281. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  282. - Pylint fixes (abutcher@redhat.com)
  283. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  284. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  285. ansible.spec file (tdawson@redhat.com)
  286. - Fix quotes (spinolacastro@gmail.com)
  287. - Use standard library for version comparison. (abutcher@redhat.com)
  288. - added docker info to the end of docker loop to direct lvm playbook.
  289. (twiest@redhat.com)
  290. - Add missing quotes (spinolacastro@gmail.com)
  291. - Adding Docker Log Options capabilities (epo@jemba.net)
  292. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  293. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  294. - Add proxy client certs to master config. (abutcher@redhat.com)
  295. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  296. - Get default values from openshift_facts (spinolacastro@gmail.com)
  297. - Cleanup (spinolacastro@gmail.com)
  298. - Add missing inventory example (spinolacastro@gmail.com)
  299. - Custom Project Config (spinolacastro@gmail.com)
  300. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  301. - Initial Package