openshift-ansible.spec 35 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.20
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible >= 1.9.4
  15. Requires: python2
  16. %description
  17. Openshift and Atomic Enterprise Ansible
  18. This repo contains Ansible code and playbooks
  19. for Openshift and Atomic Enterprise.
  20. %prep
  21. %setup -q
  22. %build
  23. # atomic-openshift-utils install
  24. pushd utils
  25. %{__python} setup.py build
  26. popd
  27. %install
  28. # Base openshift-ansible install
  29. mkdir -p %{buildroot}%{_datadir}/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  31. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  32. # openshift-ansible-bin install
  33. mkdir -p %{buildroot}%{_bindir}
  34. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  35. mkdir -p %{buildroot}/etc/bash_completion.d
  36. mkdir -p %{buildroot}/etc/openshift_ansible
  37. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  38. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  39. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  40. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  41. # Fix links
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  43. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  44. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  45. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  46. # openshift-ansible-docs install
  47. # -docs are currently just %doc, no install needed
  48. # openshift-ansible-inventory install
  49. mkdir -p %{buildroot}/etc/ansible
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  52. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  53. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  54. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  55. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  56. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  57. # openshift-ansible-playbooks install
  58. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  59. # openshift-ansible-roles install
  60. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  61. # openshift-ansible-filter-plugins install
  62. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  63. # openshift-ansible-lookup-plugins install
  64. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  65. # atomic-openshift-utils install
  66. pushd utils
  67. %{__python} setup.py install --skip-build --root %{buildroot}
  68. # Remove this line once the name change has happened
  69. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  70. mkdir -p %{buildroot}%{_datadir}/atomic-openshift-utils/
  71. cp etc/ansible.cfg %{buildroot}%{_datadir}/atomic-openshift-utils/ansible.cfg
  72. popd
  73. # Base openshift-ansible files
  74. %files
  75. %doc LICENSE.md README*
  76. %dir %{_datadir}/ansible/%{name}
  77. # ----------------------------------------------------------------------------------
  78. # openshift-ansible-bin subpackage
  79. # ----------------------------------------------------------------------------------
  80. %package bin
  81. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  82. Requires: %{name} = %{version}
  83. Requires: %{name}-inventory = %{version}
  84. Requires: %{name}-playbooks = %{version}
  85. BuildRequires: python2-devel
  86. BuildArch: noarch
  87. %description bin
  88. Scripts to make it nicer when working with hosts that are defined only by metadata.
  89. %files bin
  90. %{_bindir}/*
  91. %exclude %{_bindir}/atomic-openshift-installer
  92. %{python_sitelib}/openshift_ansible/
  93. /etc/bash_completion.d/*
  94. %config(noreplace) /etc/openshift_ansible/
  95. # ----------------------------------------------------------------------------------
  96. # openshift-ansible-docs subpackage
  97. # ----------------------------------------------------------------------------------
  98. %package docs
  99. Summary: Openshift and Atomic Enterprise Ansible documents
  100. Requires: %{name} = %{version}
  101. BuildArch: noarch
  102. %description docs
  103. %{summary}.
  104. %files docs
  105. %doc docs
  106. # ----------------------------------------------------------------------------------
  107. # openshift-ansible-inventory subpackage
  108. # ----------------------------------------------------------------------------------
  109. %package inventory
  110. Summary: Openshift and Atomic Enterprise Ansible Inventories
  111. Requires: %{name} = %{version}
  112. BuildArch: noarch
  113. %description inventory
  114. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  115. %files inventory
  116. %config(noreplace) /etc/ansible/*
  117. %dir %{_datadir}/ansible/inventory
  118. %{_datadir}/ansible/inventory/multi_inventory.py*
  119. %package inventory-aws
  120. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  121. Requires: %{name}-inventory = %{version}
  122. Requires: python-boto
  123. BuildArch: noarch
  124. %description inventory-aws
  125. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  126. %files inventory-aws
  127. %{_datadir}/ansible/inventory/aws/ec2.py*
  128. %package inventory-gce
  129. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  130. Requires: %{name}-inventory = %{version}
  131. Requires: python-libcloud >= 0.13
  132. BuildArch: noarch
  133. %description inventory-gce
  134. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  135. %files inventory-gce
  136. %{_datadir}/ansible/inventory/gce/gce.py*
  137. # ----------------------------------------------------------------------------------
  138. # openshift-ansible-playbooks subpackage
  139. # ----------------------------------------------------------------------------------
  140. %package playbooks
  141. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  142. Requires: %{name} = %{version}
  143. Requires: %{name}-roles = %{version}
  144. Requires: %{name}-lookup-plugins = %{version}
  145. Requires: %{name}-filter-plugins = %{version}
  146. BuildArch: noarch
  147. %description playbooks
  148. %{summary}.
  149. %files playbooks
  150. %{_datadir}/ansible/%{name}/playbooks
  151. # ----------------------------------------------------------------------------------
  152. # openshift-ansible-roles subpackage
  153. # ----------------------------------------------------------------------------------
  154. %package roles
  155. Summary: Openshift and Atomic Enterprise Ansible roles
  156. Requires: %{name} = %{version}
  157. Requires: %{name}-lookup-plugins = %{version}
  158. Requires: %{name}-filter-plugins = %{version}
  159. BuildArch: noarch
  160. %description roles
  161. %{summary}.
  162. %files roles
  163. %{_datadir}/ansible/%{name}/roles
  164. # ----------------------------------------------------------------------------------
  165. # openshift-ansible-filter-plugins subpackage
  166. # ----------------------------------------------------------------------------------
  167. %package filter-plugins
  168. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  169. Requires: %{name} = %{version}
  170. BuildArch: noarch
  171. Requires: pyOpenSSL
  172. %description filter-plugins
  173. %{summary}.
  174. %files filter-plugins
  175. %{_datadir}/ansible_plugins/filter_plugins
  176. # ----------------------------------------------------------------------------------
  177. # openshift-ansible-lookup-plugins subpackage
  178. # ----------------------------------------------------------------------------------
  179. %package lookup-plugins
  180. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  181. Requires: %{name} = %{version}
  182. BuildArch: noarch
  183. %description lookup-plugins
  184. %{summary}.
  185. %files lookup-plugins
  186. %{_datadir}/ansible_plugins/lookup_plugins
  187. # ----------------------------------------------------------------------------------
  188. # atomic-openshift-utils subpackage
  189. # ----------------------------------------------------------------------------------
  190. %package -n atomic-openshift-utils
  191. Summary: Atomic OpenShift Utilities
  192. BuildRequires: python-setuptools
  193. Requires: %{name}-playbooks >= %{version}
  194. Requires: python-click
  195. Requires: python-setuptools
  196. Requires: PyYAML
  197. BuildArch: noarch
  198. %description -n atomic-openshift-utils
  199. Atomic OpenShift Utilities includes
  200. - atomic-openshift-installer
  201. - other utilities
  202. %files -n atomic-openshift-utils
  203. %{python_sitelib}/ooinstall*
  204. %{_bindir}/atomic-openshift-installer
  205. %{_datadir}/atomic-openshift-utils/ansible.cfg
  206. %changelog
  207. * Thu Dec 10 2015 Thomas Wiest <twiest@redhat.com> 3.0.20-1
  208. - Revert "Automatic commit of package [openshift-ansible] release [3.0.20-1]."
  209. (twiest@redhat.com)
  210. - Automatic commit of package [openshift-ansible] release [3.0.20-1].
  211. (twiest@redhat.com)
  212. - Install base package in openshift_common for version facts
  213. (abutcher@redhat.com)
  214. - Make the install of openshift_examples optional (jtslear@gmail.com)
  215. - add support for remote command actions no support for anything but custom
  216. scripts at this time (jdiaz@redhat.com)
  217. - Remove yum / dnf duplication (sdodson@redhat.com)
  218. - Remove hacluster user during uninstall. (abutcher@redhat.com)
  219. - Simplify session secrets overrides. (abutcher@redhat.com)
  220. - Squash pcs install into one task. (abutcher@redhat.com)
  221. - Bump ansible requirement to 1.9.4 (sdodson@redhat.com)
  222. * Wed Dec 09 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.19-1
  223. - Fix version dependent image streams (sdodson@redhat.com)
  224. - atomic-openshift-installer: Error handling on yaml loading
  225. (smunilla@redhat.com)
  226. - Betterize AWS readme (jtslear@gmail.com)
  227. * Tue Dec 08 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.18-1
  228. - Pass in and use first_master_ip as dnsIP for pre 3.1 nodes.
  229. (abutcher@redhat.com)
  230. - Fix delete state (jdiaz@redhat.com)
  231. - Require pyOpenSSL (sdodson@redhat.com)
  232. - Update sync db-templates, image-streams, and quickstart-templates
  233. (sdodson@redhat.com)
  234. - Clarify the preflight port check output (sdodson@redhat.com)
  235. - Fix missing dependency version locking (sdodson@redhat.com)
  236. * Tue Dec 08 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.17-1
  237. - Improving output when gathering facts (bleanhar@redhat.com)
  238. - Bug 1287977 - Incorrect check output from atomic-openshift-installer when
  239. working with preconfigured load balancer (bleanhar@redhat.com)
  240. - Add unique AEP, OSE, and Origin BYO inventories (sdodson@redhat.com)
  241. - bring the docker udev workaround into openshift-ansible.git
  242. (jdiaz@redhat.com)
  243. - Zabbix: put in a note about trigger prototype dependency
  244. (mwoodson@redhat.com)
  245. - Zabbix: added dependency for inode disk check (mwoodson@redhat.com)
  246. - Zabbix: added dependency for disk check (mwoodson@redhat.com)
  247. - zabbix: removed ethernet graphs (mwoodson@redhat.com)
  248. - Zabbix: added trigger dependencies to certain master checks
  249. (mwoodson@redhat.com)
  250. - ManageIQ Service Account: added role for ManageIQ service account
  251. (efreiber@redhat.com)
  252. - added the pv zabbix keys (mwoodson@redhat.com)
  253. - Refactor dns options and facts. (abutcher@redhat.com)
  254. - Fix openshift_facts playbook for yum/dnf changes (jdetiber@redhat.com)
  255. - Configured master count should be 1 for pacemaker ha. (abutcher@redhat.com)
  256. - Fedora changes: (admiller@redhat.com)
  257. - Centralize etcd/schedulability logic for each host. (dgoodwin@redhat.com)
  258. - added upgrade playbook for online (sedgar@redhat.com)
  259. - Improved installation summary. (dgoodwin@redhat.com)
  260. - Fix kubernetes service ip gathering. (abutcher@redhat.com)
  261. - added docker registry cluster check (mwoodson@redhat.com)
  262. - Add warning for HA deployments with < 3 dedicated nodes.
  263. (dgoodwin@redhat.com)
  264. - Cleanup more schedulable typos. (dgoodwin@redhat.com)
  265. - Fix validation for BasicAuthPasswordIdentityProvider (tschan@puzzle.ch)
  266. - Fix ec2 instance type lookups (jdetiber@redhat.com)
  267. - remove debug logging from scc/privileged patch command (jdetiber@redhat.com)
  268. - Set api version for oc commands (jdetiber@redhat.com)
  269. - 3.1 upgrade - use --api-version for patch commands (jdetiber@redhat.com)
  270. - Fix bug when warning on no dedicated nodes. (dgoodwin@redhat.com)
  271. - Suggest dedicated nodes for an HA deployment. (dgoodwin@redhat.com)
  272. - Error out if no load balancer specified. (dgoodwin@redhat.com)
  273. - Adjust requirement for 3 masters for HA deployments. (dgoodwin@redhat.com)
  274. - Fixing 'unscheduleable' typo (bleanhar@redhat.com)
  275. - Update IMAGE_PREFIX and IMAGE_VERSION values in hawkular template
  276. (nakayamakenjiro@gmail.com)
  277. - Improved output when re-running after editing config. (dgoodwin@redhat.com)
  278. - Print a system summary after adding each. (dgoodwin@redhat.com)
  279. - Text improvements for host specification. (dgoodwin@redhat.com)
  280. - Assert etcd section written for HA installs. (dgoodwin@redhat.com)
  281. - Breakout a test fixture to reduce module size. (dgoodwin@redhat.com)
  282. - Pylint touchups. (dgoodwin@redhat.com)
  283. - Trim assertions in HA testing. (dgoodwin@redhat.com)
  284. - Test unattended HA quick install. (dgoodwin@redhat.com)
  285. - Don't prompt to continue during unattended installs. (dgoodwin@redhat.com)
  286. - Block re-use of master/node as load balancer in attended install.
  287. (dgoodwin@redhat.com)
  288. - Add -q flag to remove unwantend output (such as mirror and cache information)
  289. (urs.breu@ergon.ch)
  290. - Uninstall: only restart docker on node hosts. (abutcher@redhat.com)
  291. - Explicitly set schedulable when masters == nodes. (dgoodwin@redhat.com)
  292. - Use admin.kubeconfig for get svc ip. (abutcher@redhat.com)
  293. - Point enterprise metrics at registry.access.redhat.com/openshift3/metrics-
  294. (sdodson@redhat.com)
  295. - Make sure that OpenSSL is installed before use (fsimonce@redhat.com)
  296. - fixes for installer wrapper scaleup (jdetiber@redhat.com)
  297. - addtl aws fixes (jdetiber@redhat.com)
  298. - Fix failure when seboolean not present (jdetiber@redhat.com)
  299. - fix addNodes.yml (jdetiber@redhat.com)
  300. - more aws support for scaleup (jdetiber@redhat.com)
  301. - start of aws scaleup (jdetiber@redhat.com)
  302. - Improve scaleup playbook (jdetiber@redhat.com)
  303. - Update openshift_repos to refresh package cache on changes
  304. (jdetiber@redhat.com)
  305. - Add etcd nodes management in OpenStack (lhuard@amadeus.com)
  306. * Tue Nov 24 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.16-1
  307. - Silencing pylint branch errors for now for the atomic-openshift-installer
  308. harness (bleanhar@redhat.com)
  309. - Properly setting scheduleability for HA Master scenarios
  310. (bleanhar@redhat.com)
  311. - added graphs (mwoodson@redhat.com)
  312. - Rework setting of hostname (jdetiber@redhat.com)
  313. - Fixed a bug in the actions. It now supports changing opconditions
  314. (kwoodson@redhat.com)
  315. - Conditionally set the nodeIP (jdetiber@redhat.com)
  316. - Bug 1284991 - "atomic-openshift-installer uninstall" error when configuration
  317. file is missing. (bleanhar@redhat.com)
  318. - Avoid printing the master and node totals in the add-a-node scenario
  319. (bleanhar@redhat.com)
  320. - Fixing tests for quick_ha (bleanhar@redhat.com)
  321. - Removing a debug line (bleanhar@redhat.com)
  322. - atomic-openshift-installer: Fix lint issue (smunilla@redhat.com)
  323. - Handling preconfigured load balancers (bleanhar@redhat.com)
  324. - atomic-openshift-installer: Rename ha_proxy (smunilla@redhat.com)
  325. - atomic-openshift-installer: Reverse version and host collection
  326. (smunilla@redhat.com)
  327. - cli_installer_tests: Add test for unattended quick HA (smunilla@redhat.com)
  328. - Breakup inventory writing (smunilla@redhat.com)
  329. - Enforce 1 or 3 masters (smunilla@redhat.com)
  330. - Add interactive test (smunilla@redhat.com)
  331. - atomic-openshift-installer: HA for quick installer (smunilla@redhat.com)
  332. - Adding zbx_graph support (kwoodson@redhat.com)
  333. - Modified step params to be in order when passed as a list
  334. (kwoodson@redhat.com)
  335. - Add serviceAccountConfig.masterCA during 3.1 upgrade (jdetiber@redhat.com)
  336. - Use the identity_providers from openshift_facts instead of always using the
  337. inventory variable (jdetiber@redhat.com)
  338. - Refactor master identity provider configuration (jdetiber@redhat.com)
  339. * Fri Nov 20 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.15-1
  340. - Fixing clone group functionality. Also separating extra_vars from
  341. extra_groups (kwoodson@redhat.com)
  342. - Check the end result on bad config file (smunilla@redhat.com)
  343. - Add some tests for a bad config (smunilla@redhat.com)
  344. - atomic-openshift-installer: connect_to error handling (smunilla@redhat.com)
  345. - atomic-openshift-installer: pylint fixes (smunilla@redhat.com)
  346. - Replace map with oo_collect to support python-jinja2 <2.7
  347. (abutcher@redhat.com)
  348. - Making the uninstall playbook more flexible (bleanhar@redhat.com)
  349. - Install version dependent image streams for v1.0 and v1.1
  350. (sdodson@redhat.com)
  351. - Do not update the hostname (jdetiber@redhat.com)
  352. - Pylint fix for long line in cli docstring. (dgoodwin@redhat.com)
  353. - Default to installing OSE 3.1 instead of 3.0. (dgoodwin@redhat.com)
  354. - Fix tests on systems with openshift-ansible rpms installed.
  355. (dgoodwin@redhat.com)
  356. * Thu Nov 19 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.14-1
  357. - added metric items to zabbix for openshift online (mwoodson@redhat.com)
  358. - Updating usergroups to accept users (kwoodson@redhat.com)
  359. - Differentiate machine types on GCE (master and nodes)
  360. (romain.dossin@amadeus.com)
  361. - Uninstall - Remove systemd wants file for node (jdetiber@redhat.com)
  362. - ec2 - force !requiretty for ssh_user (jdetiber@redhat.com)
  363. - small tweaks for adding docker volume for aws master hosts
  364. (jdetiber@redhat.com)
  365. - Created role to deploy ops host monitoring (jdiaz@redhat.com)
  366. - Update certificate paths when 'names' key is provided. (abutcher@redhat.com)
  367. - add a volume on master host, in AWS provisioning (chengcheng.mu@amadeus.com)
  368. - First attempt at adding web scenarios (kwoodson@redhat.com)
  369. - Use field numbers for all formats in bin/cluster for python 2.6
  370. (abutcher@redhat.com)
  371. - atomic-openshift-installer: Correct single master case (smunilla@redhat.com)
  372. - added copr-openshift-ansible releaser, removed old rel-eng stuff.
  373. (twiest@redhat.com)
  374. - changed counter -> count (mwoodson@redhat.com)
  375. - Updating zbx_item classes to support data types for bool.
  376. (kwoodson@redhat.com)
  377. - Fix ec2 instance type override (jdetiber@redhat.com)
  378. - updated my check to support the boolean data type (mwoodson@redhat.com)
  379. - Add additive_facts_to_overwrite instead of overwriting all additive_facts
  380. (abutcher@redhat.com)
  381. - added healthz check and more pod count checks (mwoodson@redhat.com)
  382. - updating to the latest ec2.py (and re-patching with our changes).
  383. (twiest@redhat.com)
  384. - atomic-openshift-installer: Temporarily restrict to single master
  385. (smunilla@redhat.com)
  386. - openshift-ansible: Correct variable (smunilla@redhat.com)
  387. - Refactor named certificates. (abutcher@redhat.com)
  388. - atomic-openshift-utils: Version lock playbooks (smunilla@redhat.com)
  389. - Add the native ha services and configs to uninstall (jdetiber@redhat.com)
  390. - Bug 1282336 - Add additional seboolean for gluster (jdetiber@redhat.com)
  391. - Raise lifetime to 2 weeks for dynamic AWS items (jdiaz@redhat.com)
  392. - bin/cluster fix python 2.6 issue (jdetiber@redhat.com)
  393. - cluster list: break host types by subtype (lhuard@amadeus.com)
  394. - README_AWS: Add needed dependency (c.witt.1900@gmail.com)
  395. - Fix invalid sudo command test (takayoshi@gmail.com)
  396. - Docs: Fedora: Add missing dependencies and update to dnf. (public@omeid.me)
  397. - Gate upgrade steps for 3.0 to 3.1 upgrade (jdetiber@redhat.com)
  398. - added the tito and copr_cli roles (twiest@redhat.com)
  399. - pylint openshift_facts (jdetiber@redhat.com)
  400. - Update etcd default facts setting (jdetiber@redhat.com)
  401. - Update master facts prior to upgrading incase facts are missing.
  402. (abutcher@redhat.com)
  403. - pre-upgrade-check: differentiates between port and targetPort in output
  404. (smilner@redhat.com)
  405. - Better structure the output of the list playbook (lhuard@amadeus.com)
  406. - Add the sub-host-type tag to the libvirt VMs (lhuard@amadeus.com)
  407. - atomic-openshift-installer: Update nopwd sudo test (smunilla@redhat.com)
  408. - Fix pylint import errors for utils/test/. (dgoodwin@redhat.com)
  409. - atomic-openshift-installer: Update prompts and help messages
  410. (smunilla@redhat.com)
  411. - Dependencies need to be added when a create occurs on SLA object.
  412. (kwoodson@redhat.com)
  413. - Test additions for cli_installer:get_hosts_to_install_on
  414. (bleanhar@redhat.com)
  415. - adding itservice (kwoodson@redhat.com)
  416. - remove netaddr dependency (tob@butter.sh)
  417. - Add pyOpenSSL to dependencies for Fedora. (public@omeid.me)
  418. - Vagrant RHEL registration cleanup (pep@redhat.com)
  419. - RH subscription: optional satellite and pkg update (pep@redhat.com)
  420. * Tue Nov 17 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.13-1
  421. - The aep3 images changed locations. (bleanhar@redhat.com)
  422. - atomic-openshift-installer: Correct single master case (smunilla@redhat.com)
  423. - atomic-openshift-installer: Temporarily restrict to single master
  424. (smunilla@redhat.com)
  425. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.12-1
  426. - Sync with the latest image streams (sdodson@redhat.com)
  427. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.11-1
  428. - Migrate xpaas content from pre v1.1.0 (sdodson@redhat.com)
  429. - Import latest xpaas templates and image streams (sdodson@redhat.com)
  430. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.10-1
  431. - Fix update error for templates that didn't previously exist
  432. (jdetiber@redhat.com)
  433. - General cleanup of v3_0_to_v3_1/upgrade.yml (jdetiber@redhat.com)
  434. - Add zabbix pieces to hold AWS S3 bucket stats (jdiaz@redhat.com)
  435. - add ansible dep to vagrant doc (jdetiber@redhat.com)
  436. - oo_filter: don't fail when attribute is not defined (tob@butter.sh)
  437. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.9-1
  438. - Refactor upgrade playbook(s) (jdetiber@redhat.com)
  439. * Tue Nov 10 2015 Scott Dodson <sdodson@redhat.com> 3.0.8-1
  440. - Add origin-clients to uninstall playbook. (abutcher@redhat.com)
  441. - examples: include logging and metrics infrastructure (lmeyer@redhat.com)
  442. - Add separate step to enable services during upgrade. (dgoodwin@redhat.com)
  443. - Update tests now that cli is not asking for rpm/container install
  444. (smunilla@redhat.com)
  445. - atomic-openshift-installer: Remove question for container install
  446. (smunilla@redhat.com)
  447. - Remove references to multi_ec2.py (jdetiber@redhat.com)
  448. - 1279746: Fix leftover disabled features line in config template.
  449. (dgoodwin@redhat.com)
  450. - 1279734: Ensure services are enabled after upgrade. (dgoodwin@redhat.com)
  451. - Fix missing etcd_data_dir bug. (dgoodwin@redhat.com)
  452. - Package the default ansible.cfg with atomic-openshift-utils.
  453. (dgoodwin@redhat.com)
  454. - Add ldap auth identity provider to example inventory. (abutcher@redhat.com)
  455. - Read etcd data dir from appropriate config file. (dgoodwin@redhat.com)
  456. - atomic-openshift-installer: Generate inventory off hosts_to_run_on
  457. (smunilla@redhat.com)
  458. - Various fixes related to connect_to (bleanhar@redhat.com)
  459. - Remove upgrade playbook restriction on 3.0.2. (dgoodwin@redhat.com)
  460. - Conditionals for flannel etcd client certs. (abutcher@redhat.com)
  461. - New `iptablesSyncPeriod` field in node configuration (abutcher@redhat.com)
  462. - Fix indentation on when (jdetiber@redhat.com)
  463. - Bug 1278863 - Error using openshift_pkg_version (jdetiber@redhat.com)
  464. - more cleanup of names (mwoodson@redhat.com)
  465. - Missing conditionals for api/controller sysconfig. (abutcher@redhat.com)
  466. - Updating the atomic-openshift-isntaller local connection logic for the
  467. connect_to addition. (bleanhar@redhat.com)
  468. - cleaned up network checks (mwoodson@redhat.com)
  469. - Minor upgrade improvements. (dgoodwin@redhat.com)
  470. - Wait for cluster to recover after pcs resource restart. (abutcher@redhat.com)
  471. - Bug 1278245 - Failed to add node to existing env using atomic-openshift-
  472. installer (bleanhar@redhat.com)
  473. - remove debug statement (jdetiber@redhat.com)
  474. - Fix removal of kubernetesMasterConfig.apiLevels (jdetiber@redhat.com)
  475. - atomic-openshift-installer: Better specification of ansible connection point
  476. (smunilla@redhat.com)
  477. - Fix issues related to upgrade packages being unavailable
  478. (jdetiber@redhat.com)
  479. - added network checks. also updated item prototype code to support more
  480. (mwoodson@redhat.com)
  481. - Fix data_dir for 3.0 deployments (jdetiber@redhat.com)
  482. - Fix apiLevels modifications (jdetiber@redhat.com)
  483. - Fix creation of origin symlink when dir already exists. (dgoodwin@redhat.com)
  484. - apiLevel changes (jdetiber@redhat.com)
  485. - Write new config to disk after successful upgrade. (dgoodwin@redhat.com)
  486. - Fix pylint errors with getting hosts to run on. (dgoodwin@redhat.com)
  487. - Remove v1beta3 by default for kube_nfs_volumes (jdetiber@redhat.com)
  488. - Add pre-upgrade script to be run on first master. (dgoodwin@redhat.com)
  489. - Start to handle pacemaker ha during upgrade (abutcher@redhat.com)
  490. - Fix lb group related errors (jdetiber@redhat.com)
  491. - Fix file check conditional. (abutcher@redhat.com)
  492. - Don't check for certs in data_dir just raise when they can't be found. Fix
  493. typo. (abutcher@redhat.com)
  494. - exclude atomic-openshift-installer from bin subpackage (tdawson@redhat.com)
  495. - add master_hostnames definition for upgrade (jdetiber@redhat.com)
  496. - Additional upgrade enhancements (jdetiber@redhat.com)
  497. - Handle backups for separate etcd hosts if necessary. (dgoodwin@redhat.com)
  498. - Further upgrade improvements (jdetiber@redhat.com)
  499. - Upgrade improvements (dgoodwin@redhat.com)
  500. - Bug 1278243 - Confusing prompt from atomic-openshift-installer
  501. (bleanhar@redhat.com)
  502. - Bug 1278244 - Previously there was no way to add a node in unattended mode
  503. (bleanhar@redhat.com)
  504. - Revert to defaults (abutcher@redhat.com)
  505. - Bug 1278244 - Incorrect node information gathered by atomic-openshift-
  506. installer (bleanhar@redhat.com)
  507. - atomic-openshift-installer's unattended mode wasn't work with --force for all
  508. cases (bleanhar@redhat.com)
  509. - Making it easier to use pre-release content (bleanhar@redhat.com)
  510. - The uninstall playbook needs to remove /run/openshift-sdn
  511. (bleanhar@redhat.com)
  512. - Various HA changes for pacemaker and native methods. (abutcher@redhat.com)
  513. - Bug 1274201 - Fixing non-root installations if using a local connection
  514. (bleanhar@redhat.com)
  515. - Bug 1274201 - Fixing sudo non-interactive test (bleanhar@redhat.com)
  516. - Bug 1277592 - SDN MTU has hardcoded default (jdetiber@redhat.com)
  517. - Atomic Enterprise/OpenShift Enterprise merge update (jdetiber@redhat.com)
  518. - fix dueling controllers - without controllerLeaseTTL set in config, multiple
  519. controllers will attempt to start (jdetiber@redhat.com)
  520. - default to source persistence for haproxy (jdetiber@redhat.com)
  521. - hardcode openshift binaries for now (jdetiber@redhat.com)
  522. - more tweaks (jdetiber@redhat.com)
  523. - more tweaks (jdetiber@redhat.com)
  524. - additional ha related updates (jdetiber@redhat.com)
  525. - additional native ha changes (abutcher@redhat.com)
  526. - Start of true master ha (jdetiber@redhat.com)
  527. - Atomic Enterprise related changes. (avagarwa@redhat.com)
  528. - Remove pacemaker bits. (abutcher@redhat.com)
  529. - Override hosts deployment_type fact for version we're upgrading to.
  530. (dgoodwin@redhat.com)
  531. - Pylint fixes for config upgrade module. (dgoodwin@redhat.com)
  532. - Disable proxy cert config upgrade until certs being generated.
  533. (dgoodwin@redhat.com)
  534. - remove debug line (florian.lambert@enovance.com)
  535. - [roles/openshift_master_certificates/tasks/main.yml] Fix variable
  536. openshift.master.all_hostnames to openshift.common.all_hostnames
  537. (florian.lambert@enovance.com)
  538. - Fix bug with not upgrading openshift-master to atomic-openshift-master.
  539. (dgoodwin@redhat.com)
  540. - Adding aws and gce packages to ansible-inventory (kwoodson@redhat.com)
  541. - Fix subpackage dependencies (jdetiber@redhat.com)
  542. - Refactor common group evaluation to avoid duplication (jdetiber@redhat.com)
  543. - common/openshift-cluster: Scaleup playbook (smunilla@redhat.com)
  544. - Fix bug from module rename. (dgoodwin@redhat.com)
  545. - Fix bug with default ansible playbook dir. (dgoodwin@redhat.com)
  546. - Use the base package upgrade version so we can check things earlier.
  547. (dgoodwin@redhat.com)
  548. - Skip fail if enterprise deployment type depending on version.
  549. (dgoodwin@redhat.com)
  550. - Add debug output for location of etcd backup. (dgoodwin@redhat.com)
  551. - Filter internal hostnames from the list of parsed names.
  552. (abutcher@redhat.com)
  553. - Move config upgrade to correct place, fix node facts. (dgoodwin@redhat.com)
  554. - Add custom certificates to serving info in master configuration.
  555. (abutcher@redhat.com)
  556. - Add in proxyClientInfo if missing during config upgrade.
  557. (dgoodwin@redhat.com)
  558. - Implement master-config.yaml upgrade for v1beta3 apiLevel removal.
  559. (dgoodwin@redhat.com)
  560. - Fix installer upgrade bug following pylint fix. (dgoodwin@redhat.com)
  561. - Document the new version field for installer config. (dgoodwin@redhat.com)
  562. - Remove my username from some test data. (dgoodwin@redhat.com)
  563. - Add a simple version for the installer config file. (dgoodwin@redhat.com)
  564. - Pylint fix. (dgoodwin@redhat.com)
  565. - Fix issue with master.proxy-client.{crt,key} and omit. (abutcher@redhat.com)
  566. - initial module framework (jdetiber@redhat.com)
  567. - Better info prior to initiating upgrade. (dgoodwin@redhat.com)
  568. - Fix etcd backup bug with not-yet-created /var/lib/origin symlink
  569. (dgoodwin@redhat.com)
  570. - Print info after upgrade completes. (dgoodwin@redhat.com)
  571. - Automatically upgrade legacy config files. (dgoodwin@redhat.com)
  572. - Remove devel fail and let upgrade proceed. (dgoodwin@redhat.com)
  573. - Add utils subpackage missing dep on openshift-ansible-roles.
  574. (dgoodwin@redhat.com)
  575. - Generate timestamped etcd backups. (dgoodwin@redhat.com)
  576. - Add etcd_data_dir fact. (dgoodwin@redhat.com)
  577. - Functional disk space checking for etcd backup. (dgoodwin@redhat.com)
  578. - First cut at checking available disk space for etcd backup.
  579. (dgoodwin@redhat.com)
  580. - Block upgrade if targetting enterprise deployment type. (dgoodwin@redhat.com)
  581. - Change flannel registration default values (sbaubeau@redhat.com)
  582. - Remove empty notify section (sbaubeau@redhat.com)
  583. - Check etcd certs exist for flannel when its support is enabled
  584. (sbaubeau@redhat.com)
  585. - Fix when neither use_openshift_sdn nor use_flannel are specified
  586. (sbaubeau@redhat.com)
  587. - Generate etcd certificats for flannel when is not embedded
  588. (sbaubeau@redhat.com)
  589. - Add missing 2nd true parameters to default Jinja filter (sbaubeau@redhat.com)
  590. - Use 'command' module instead of 'shell' (sbaubeau@redhat.com)
  591. - Add flannel modules documentation (sbaubeau@redhat.com)
  592. - Only remove IPv4 address from docker bridge (sbaubeau@redhat.com)
  593. - Remove multiple use_flannel fact definition (sbaubeau@redhat.com)
  594. - Ensure openshift-sdn and flannel can't be used at the same time
  595. (sbaubeau@redhat.com)
  596. - Add flannel support (sbaubeau@redhat.com)
  597. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  598. - added the %%util in zabbix (mwoodson@redhat.com)
  599. - atomic-openshift-installer: Correct default playbook directory
  600. (smunilla@redhat.com)
  601. - Support for gce (kwoodson@redhat.com)
  602. - fixed a dumb naming mistake (mwoodson@redhat.com)
  603. - added disk tps checks to zabbix (mwoodson@redhat.com)
  604. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  605. - atomic-openshift-installer: Add default openshift-ansible-playbook
  606. (smunilla@redhat.com)
  607. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  608. - ooinstall: Update local install check (smunilla@redhat.com)
  609. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  610. - Moving to Openshift Etcd application (mmahut@redhat.com)
  611. - Add all the possible servicenames to openshift_all_hostnames for masters
  612. (sdodson@redhat.com)
  613. - Adding openshift.node.etcd items (mmahut@redhat.com)
  614. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  615. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  616. - split inventory into subpackages (tdawson@redhat.com)
  617. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  618. warning (mwoodson@redhat.com)
  619. - Rename install_transactions module to openshift_ansible.
  620. (dgoodwin@redhat.com)
  621. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  622. - Add utils subpackage missing dep on openshift-ansible-roles.
  623. (dgoodwin@redhat.com)
  624. - Disable requiretty for only the openshift user (error@ioerror.us)
  625. - Don't require tty to run sudo (error@ioerror.us)
  626. - Attempt to remove the various interfaces left over from an install
  627. (bleanhar@redhat.com)
  628. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  629. - Disable OpenShift features if installing Atomic Enterprise
  630. (jdetiber@redhat.com)
  631. - Use default playbooks if available. (dgoodwin@redhat.com)
  632. - Add uninstall subcommand. (dgoodwin@redhat.com)
  633. - Add subcommands to CLI. (dgoodwin@redhat.com)
  634. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  635. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  636. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  637. dependency (kwoodson@redhat.com)
  638. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  639. (abutcher@redhat.com)
  640. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  641. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  642. - Updating multi_ec2 to support extra_vars and extra_groups
  643. (kwoodson@redhat.com)
  644. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  645. - README_AEP.md: update instructions for creating router and registry
  646. (jlebon@redhat.com)
  647. - README_AEP: Various fixes (walters@verbum.org)
  648. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  649. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  650. - remove debugging pauses (jdetiber@redhat.com)
  651. - make storage plugin dependency installation more flexible
  652. (jdetiber@redhat.com)
  653. - Install storage plugin dependencies (jdetiber@redhat.com)
  654. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  655. - Removing spec files. (kwoodson@redhat.com)
  656. - Updated example (kwoodson@redhat.com)
  657. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  658. (kwoodson@redhat.com)
  659. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  660. (kwoodson@redhat.com)
  661. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  662. (kwoodson@redhat.com)
  663. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  664. (kwoodson@redhat.com)
  665. - Adding tito releasers configuration (bleanhar@redhat.com)
  666. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  667. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  668. (kwoodson@redhat.com)
  669. - Start tracking docker info execution time (jdiaz@redhat.com)
  670. - The uninstall playbook should remove the kubeconfig for non-root installs
  671. (bleanhar@redhat.com)
  672. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  673. - add examples for SDN configuration (jdetiber@redhat.com)
  674. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  675. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  676. - Pylint fixes (abutcher@redhat.com)
  677. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  678. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  679. ansible.spec file (tdawson@redhat.com)
  680. - Fix quotes (spinolacastro@gmail.com)
  681. - Use standard library for version comparison. (abutcher@redhat.com)
  682. - added docker info to the end of docker loop to direct lvm playbook.
  683. (twiest@redhat.com)
  684. - Add missing quotes (spinolacastro@gmail.com)
  685. - Adding Docker Log Options capabilities (epo@jemba.net)
  686. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  687. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  688. - Add proxy client certs to master config. (abutcher@redhat.com)
  689. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  690. - Get default values from openshift_facts (spinolacastro@gmail.com)
  691. - Cleanup (spinolacastro@gmail.com)
  692. - Add missing inventory example (spinolacastro@gmail.com)
  693. - Custom Project Config (spinolacastro@gmail.com)
  694. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  695. - Initial Package