openshift-ansible.spec 34 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.17
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible >= 1.9.3
  15. Requires: python2
  16. %description
  17. Openshift and Atomic Enterprise Ansible
  18. This repo contains Ansible code and playbooks
  19. for Openshift and Atomic Enterprise.
  20. %prep
  21. %setup -q
  22. %build
  23. # atomic-openshift-utils install
  24. pushd utils
  25. %{__python} setup.py build
  26. popd
  27. %install
  28. # Base openshift-ansible install
  29. mkdir -p %{buildroot}%{_datadir}/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  31. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  32. # openshift-ansible-bin install
  33. mkdir -p %{buildroot}%{_bindir}
  34. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  35. mkdir -p %{buildroot}/etc/bash_completion.d
  36. mkdir -p %{buildroot}/etc/openshift_ansible
  37. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  38. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  39. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  40. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  41. # Fix links
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  43. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  44. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  45. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  46. # openshift-ansible-docs install
  47. # -docs are currently just %doc, no install needed
  48. # openshift-ansible-inventory install
  49. mkdir -p %{buildroot}/etc/ansible
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  52. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  53. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  54. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  55. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  56. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  57. # openshift-ansible-playbooks install
  58. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  59. # openshift-ansible-roles install
  60. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  61. # openshift-ansible-filter-plugins install
  62. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  63. # openshift-ansible-lookup-plugins install
  64. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  65. # atomic-openshift-utils install
  66. pushd utils
  67. %{__python} setup.py install --skip-build --root %{buildroot}
  68. # Remove this line once the name change has happened
  69. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  70. mkdir -p %{buildroot}%{_datadir}/atomic-openshift-utils/
  71. cp etc/ansible.cfg %{buildroot}%{_datadir}/atomic-openshift-utils/ansible.cfg
  72. popd
  73. # Base openshift-ansible files
  74. %files
  75. %doc LICENSE.md README*
  76. %dir %{_datadir}/ansible/%{name}
  77. # ----------------------------------------------------------------------------------
  78. # openshift-ansible-bin subpackage
  79. # ----------------------------------------------------------------------------------
  80. %package bin
  81. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  82. Requires: %{name} = %{version}
  83. Requires: %{name}-inventory = %{version}
  84. Requires: %{name}-playbooks = %{version}
  85. BuildRequires: python2-devel
  86. BuildArch: noarch
  87. %description bin
  88. Scripts to make it nicer when working with hosts that are defined only by metadata.
  89. %files bin
  90. %{_bindir}/*
  91. %exclude %{_bindir}/atomic-openshift-installer
  92. %{python_sitelib}/openshift_ansible/
  93. /etc/bash_completion.d/*
  94. %config(noreplace) /etc/openshift_ansible/
  95. # ----------------------------------------------------------------------------------
  96. # openshift-ansible-docs subpackage
  97. # ----------------------------------------------------------------------------------
  98. %package docs
  99. Summary: Openshift and Atomic Enterprise Ansible documents
  100. Requires: %{name} = %{version}
  101. BuildArch: noarch
  102. %description docs
  103. %{summary}.
  104. %files docs
  105. %doc docs
  106. # ----------------------------------------------------------------------------------
  107. # openshift-ansible-inventory subpackage
  108. # ----------------------------------------------------------------------------------
  109. %package inventory
  110. Summary: Openshift and Atomic Enterprise Ansible Inventories
  111. Requires: %{name} = %{version}
  112. BuildArch: noarch
  113. %description inventory
  114. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  115. %files inventory
  116. %config(noreplace) /etc/ansible/*
  117. %dir %{_datadir}/ansible/inventory
  118. %{_datadir}/ansible/inventory/multi_inventory.py*
  119. %package inventory-aws
  120. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  121. Requires: %{name}-inventory = %{version}
  122. Requires: python-boto
  123. BuildArch: noarch
  124. %description inventory-aws
  125. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  126. %files inventory-aws
  127. %{_datadir}/ansible/inventory/aws/ec2.py*
  128. %package inventory-gce
  129. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  130. Requires: %{name}-inventory = %{version}
  131. Requires: python-libcloud >= 0.13
  132. BuildArch: noarch
  133. %description inventory-gce
  134. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  135. %files inventory-gce
  136. %{_datadir}/ansible/inventory/gce/gce.py*
  137. # ----------------------------------------------------------------------------------
  138. # openshift-ansible-playbooks subpackage
  139. # ----------------------------------------------------------------------------------
  140. %package playbooks
  141. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  142. Requires: %{name} = %{version}
  143. Requires: %{name}-roles = %{version}
  144. Requires: %{name}-lookup-plugins = %{version}
  145. Requires: %{name}-filter-plugins = %{version}
  146. BuildArch: noarch
  147. %description playbooks
  148. %{summary}.
  149. %files playbooks
  150. %{_datadir}/ansible/%{name}/playbooks
  151. # ----------------------------------------------------------------------------------
  152. # openshift-ansible-roles subpackage
  153. # ----------------------------------------------------------------------------------
  154. %package roles
  155. Summary: Openshift and Atomic Enterprise Ansible roles
  156. Requires: %{name} = %{version}
  157. Requires: %{name}-lookup-plugins = %{version}
  158. Requires: %{name}-filter-plugins = %{version}
  159. BuildArch: noarch
  160. %description roles
  161. %{summary}.
  162. %files roles
  163. %{_datadir}/ansible/%{name}/roles
  164. # ----------------------------------------------------------------------------------
  165. # openshift-ansible-filter-plugins subpackage
  166. # ----------------------------------------------------------------------------------
  167. %package filter-plugins
  168. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  169. Requires: %{name} = %{version}
  170. BuildArch: noarch
  171. %description filter-plugins
  172. %{summary}.
  173. %files filter-plugins
  174. %{_datadir}/ansible_plugins/filter_plugins
  175. # ----------------------------------------------------------------------------------
  176. # openshift-ansible-lookup-plugins subpackage
  177. # ----------------------------------------------------------------------------------
  178. %package lookup-plugins
  179. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  180. Requires: %{name} = %{version}
  181. BuildArch: noarch
  182. %description lookup-plugins
  183. %{summary}.
  184. %files lookup-plugins
  185. %{_datadir}/ansible_plugins/lookup_plugins
  186. # ----------------------------------------------------------------------------------
  187. # atomic-openshift-utils subpackage
  188. # ----------------------------------------------------------------------------------
  189. %package -n atomic-openshift-utils
  190. Summary: Atomic OpenShift Utilities
  191. BuildRequires: python-setuptools
  192. Requires: %{name}-playbooks >= %{version}
  193. Requires: python-click
  194. Requires: python-setuptools
  195. Requires: PyYAML
  196. BuildArch: noarch
  197. %description -n atomic-openshift-utils
  198. Atomic OpenShift Utilities includes
  199. - atomic-openshift-installer
  200. - other utilities
  201. %files -n atomic-openshift-utils
  202. %{python_sitelib}/ooinstall*
  203. %{_bindir}/atomic-openshift-installer
  204. %{_datadir}/atomic-openshift-utils/ansible.cfg
  205. %changelog
  206. * Tue Dec 08 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.17-1
  207. - Improving output when gathering facts (bleanhar@redhat.com)
  208. - Bug 1287977 - Incorrect check output from atomic-openshift-installer when
  209. working with preconfigured load balancer (bleanhar@redhat.com)
  210. - Add unique AEP, OSE, and Origin BYO inventories (sdodson@redhat.com)
  211. - bring the docker udev workaround into openshift-ansible.git
  212. (jdiaz@redhat.com)
  213. - Zabbix: put in a note about trigger prototype dependency
  214. (mwoodson@redhat.com)
  215. - Zabbix: added dependency for inode disk check (mwoodson@redhat.com)
  216. - Zabbix: added dependency for disk check (mwoodson@redhat.com)
  217. - zabbix: removed ethernet graphs (mwoodson@redhat.com)
  218. - Zabbix: added trigger dependencies to certain master checks
  219. (mwoodson@redhat.com)
  220. - ManageIQ Service Account: added role for ManageIQ service account
  221. (efreiber@redhat.com)
  222. - added the pv zabbix keys (mwoodson@redhat.com)
  223. - Refactor dns options and facts. (abutcher@redhat.com)
  224. - Fix openshift_facts playbook for yum/dnf changes (jdetiber@redhat.com)
  225. - Configured master count should be 1 for pacemaker ha. (abutcher@redhat.com)
  226. - Fedora changes: (admiller@redhat.com)
  227. - Centralize etcd/schedulability logic for each host. (dgoodwin@redhat.com)
  228. - added upgrade playbook for online (sedgar@redhat.com)
  229. - Improved installation summary. (dgoodwin@redhat.com)
  230. - Fix kubernetes service ip gathering. (abutcher@redhat.com)
  231. - added docker registry cluster check (mwoodson@redhat.com)
  232. - Add warning for HA deployments with < 3 dedicated nodes.
  233. (dgoodwin@redhat.com)
  234. - Cleanup more schedulable typos. (dgoodwin@redhat.com)
  235. - Fix validation for BasicAuthPasswordIdentityProvider (tschan@puzzle.ch)
  236. - Fix ec2 instance type lookups (jdetiber@redhat.com)
  237. - remove debug logging from scc/privileged patch command (jdetiber@redhat.com)
  238. - Set api version for oc commands (jdetiber@redhat.com)
  239. - 3.1 upgrade - use --api-version for patch commands (jdetiber@redhat.com)
  240. - Fix bug when warning on no dedicated nodes. (dgoodwin@redhat.com)
  241. - Suggest dedicated nodes for an HA deployment. (dgoodwin@redhat.com)
  242. - Error out if no load balancer specified. (dgoodwin@redhat.com)
  243. - Adjust requirement for 3 masters for HA deployments. (dgoodwin@redhat.com)
  244. - Fixing 'unscheduleable' typo (bleanhar@redhat.com)
  245. - Update IMAGE_PREFIX and IMAGE_VERSION values in hawkular template
  246. (nakayamakenjiro@gmail.com)
  247. - Improved output when re-running after editing config. (dgoodwin@redhat.com)
  248. - Print a system summary after adding each. (dgoodwin@redhat.com)
  249. - Text improvements for host specification. (dgoodwin@redhat.com)
  250. - Assert etcd section written for HA installs. (dgoodwin@redhat.com)
  251. - Breakout a test fixture to reduce module size. (dgoodwin@redhat.com)
  252. - Pylint touchups. (dgoodwin@redhat.com)
  253. - Trim assertions in HA testing. (dgoodwin@redhat.com)
  254. - Test unattended HA quick install. (dgoodwin@redhat.com)
  255. - Don't prompt to continue during unattended installs. (dgoodwin@redhat.com)
  256. - Block re-use of master/node as load balancer in attended install.
  257. (dgoodwin@redhat.com)
  258. - Add -q flag to remove unwantend output (such as mirror and cache information)
  259. (urs.breu@ergon.ch)
  260. - Uninstall: only restart docker on node hosts. (abutcher@redhat.com)
  261. - Explicitly set schedulable when masters == nodes. (dgoodwin@redhat.com)
  262. - Use admin.kubeconfig for get svc ip. (abutcher@redhat.com)
  263. - Point enterprise metrics at registry.access.redhat.com/openshift3/metrics-
  264. (sdodson@redhat.com)
  265. - Make sure that OpenSSL is installed before use (fsimonce@redhat.com)
  266. - fixes for installer wrapper scaleup (jdetiber@redhat.com)
  267. - addtl aws fixes (jdetiber@redhat.com)
  268. - Fix failure when seboolean not present (jdetiber@redhat.com)
  269. - fix addNodes.yml (jdetiber@redhat.com)
  270. - more aws support for scaleup (jdetiber@redhat.com)
  271. - start of aws scaleup (jdetiber@redhat.com)
  272. - Improve scaleup playbook (jdetiber@redhat.com)
  273. - Update openshift_repos to refresh package cache on changes
  274. (jdetiber@redhat.com)
  275. - Add etcd nodes management in OpenStack (lhuard@amadeus.com)
  276. * Tue Nov 24 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.16-1
  277. - Silencing pylint branch errors for now for the atomic-openshift-installer
  278. harness (bleanhar@redhat.com)
  279. - Properly setting scheduleability for HA Master scenarios
  280. (bleanhar@redhat.com)
  281. - added graphs (mwoodson@redhat.com)
  282. - Rework setting of hostname (jdetiber@redhat.com)
  283. - Fixed a bug in the actions. It now supports changing opconditions
  284. (kwoodson@redhat.com)
  285. - Conditionally set the nodeIP (jdetiber@redhat.com)
  286. - Bug 1284991 - "atomic-openshift-installer uninstall" error when configuration
  287. file is missing. (bleanhar@redhat.com)
  288. - Avoid printing the master and node totals in the add-a-node scenario
  289. (bleanhar@redhat.com)
  290. - Fixing tests for quick_ha (bleanhar@redhat.com)
  291. - Removing a debug line (bleanhar@redhat.com)
  292. - atomic-openshift-installer: Fix lint issue (smunilla@redhat.com)
  293. - Handling preconfigured load balancers (bleanhar@redhat.com)
  294. - atomic-openshift-installer: Rename ha_proxy (smunilla@redhat.com)
  295. - atomic-openshift-installer: Reverse version and host collection
  296. (smunilla@redhat.com)
  297. - cli_installer_tests: Add test for unattended quick HA (smunilla@redhat.com)
  298. - Breakup inventory writing (smunilla@redhat.com)
  299. - Enforce 1 or 3 masters (smunilla@redhat.com)
  300. - Add interactive test (smunilla@redhat.com)
  301. - atomic-openshift-installer: HA for quick installer (smunilla@redhat.com)
  302. - Adding zbx_graph support (kwoodson@redhat.com)
  303. - Modified step params to be in order when passed as a list
  304. (kwoodson@redhat.com)
  305. - Add serviceAccountConfig.masterCA during 3.1 upgrade (jdetiber@redhat.com)
  306. - Use the identity_providers from openshift_facts instead of always using the
  307. inventory variable (jdetiber@redhat.com)
  308. - Refactor master identity provider configuration (jdetiber@redhat.com)
  309. * Fri Nov 20 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.15-1
  310. - Fixing clone group functionality. Also separating extra_vars from
  311. extra_groups (kwoodson@redhat.com)
  312. - Check the end result on bad config file (smunilla@redhat.com)
  313. - Add some tests for a bad config (smunilla@redhat.com)
  314. - atomic-openshift-installer: connect_to error handling (smunilla@redhat.com)
  315. - atomic-openshift-installer: pylint fixes (smunilla@redhat.com)
  316. - Replace map with oo_collect to support python-jinja2 <2.7
  317. (abutcher@redhat.com)
  318. - Making the uninstall playbook more flexible (bleanhar@redhat.com)
  319. - Install version dependent image streams for v1.0 and v1.1
  320. (sdodson@redhat.com)
  321. - Do not update the hostname (jdetiber@redhat.com)
  322. - Pylint fix for long line in cli docstring. (dgoodwin@redhat.com)
  323. - Default to installing OSE 3.1 instead of 3.0. (dgoodwin@redhat.com)
  324. - Fix tests on systems with openshift-ansible rpms installed.
  325. (dgoodwin@redhat.com)
  326. * Thu Nov 19 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.14-1
  327. - added metric items to zabbix for openshift online (mwoodson@redhat.com)
  328. - Updating usergroups to accept users (kwoodson@redhat.com)
  329. - Differentiate machine types on GCE (master and nodes)
  330. (romain.dossin@amadeus.com)
  331. - Uninstall - Remove systemd wants file for node (jdetiber@redhat.com)
  332. - ec2 - force !requiretty for ssh_user (jdetiber@redhat.com)
  333. - small tweaks for adding docker volume for aws master hosts
  334. (jdetiber@redhat.com)
  335. - Created role to deploy ops host monitoring (jdiaz@redhat.com)
  336. - Update certificate paths when 'names' key is provided. (abutcher@redhat.com)
  337. - add a volume on master host, in AWS provisioning (chengcheng.mu@amadeus.com)
  338. - First attempt at adding web scenarios (kwoodson@redhat.com)
  339. - Use field numbers for all formats in bin/cluster for python 2.6
  340. (abutcher@redhat.com)
  341. - atomic-openshift-installer: Correct single master case (smunilla@redhat.com)
  342. - added copr-openshift-ansible releaser, removed old rel-eng stuff.
  343. (twiest@redhat.com)
  344. - changed counter -> count (mwoodson@redhat.com)
  345. - Updating zbx_item classes to support data types for bool.
  346. (kwoodson@redhat.com)
  347. - Fix ec2 instance type override (jdetiber@redhat.com)
  348. - updated my check to support the boolean data type (mwoodson@redhat.com)
  349. - Add additive_facts_to_overwrite instead of overwriting all additive_facts
  350. (abutcher@redhat.com)
  351. - added healthz check and more pod count checks (mwoodson@redhat.com)
  352. - updating to the latest ec2.py (and re-patching with our changes).
  353. (twiest@redhat.com)
  354. - atomic-openshift-installer: Temporarily restrict to single master
  355. (smunilla@redhat.com)
  356. - openshift-ansible: Correct variable (smunilla@redhat.com)
  357. - Refactor named certificates. (abutcher@redhat.com)
  358. - atomic-openshift-utils: Version lock playbooks (smunilla@redhat.com)
  359. - Add the native ha services and configs to uninstall (jdetiber@redhat.com)
  360. - Bug 1282336 - Add additional seboolean for gluster (jdetiber@redhat.com)
  361. - Raise lifetime to 2 weeks for dynamic AWS items (jdiaz@redhat.com)
  362. - bin/cluster fix python 2.6 issue (jdetiber@redhat.com)
  363. - cluster list: break host types by subtype (lhuard@amadeus.com)
  364. - README_AWS: Add needed dependency (c.witt.1900@gmail.com)
  365. - Fix invalid sudo command test (takayoshi@gmail.com)
  366. - Docs: Fedora: Add missing dependencies and update to dnf. (public@omeid.me)
  367. - Gate upgrade steps for 3.0 to 3.1 upgrade (jdetiber@redhat.com)
  368. - added the tito and copr_cli roles (twiest@redhat.com)
  369. - pylint openshift_facts (jdetiber@redhat.com)
  370. - Update etcd default facts setting (jdetiber@redhat.com)
  371. - Update master facts prior to upgrading incase facts are missing.
  372. (abutcher@redhat.com)
  373. - pre-upgrade-check: differentiates between port and targetPort in output
  374. (smilner@redhat.com)
  375. - Better structure the output of the list playbook (lhuard@amadeus.com)
  376. - Add the sub-host-type tag to the libvirt VMs (lhuard@amadeus.com)
  377. - atomic-openshift-installer: Update nopwd sudo test (smunilla@redhat.com)
  378. - Fix pylint import errors for utils/test/. (dgoodwin@redhat.com)
  379. - atomic-openshift-installer: Update prompts and help messages
  380. (smunilla@redhat.com)
  381. - Dependencies need to be added when a create occurs on SLA object.
  382. (kwoodson@redhat.com)
  383. - Test additions for cli_installer:get_hosts_to_install_on
  384. (bleanhar@redhat.com)
  385. - adding itservice (kwoodson@redhat.com)
  386. - remove netaddr dependency (tob@butter.sh)
  387. - Add pyOpenSSL to dependencies for Fedora. (public@omeid.me)
  388. - Vagrant RHEL registration cleanup (pep@redhat.com)
  389. - RH subscription: optional satellite and pkg update (pep@redhat.com)
  390. * Tue Nov 17 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.13-1
  391. - The aep3 images changed locations. (bleanhar@redhat.com)
  392. - atomic-openshift-installer: Correct single master case (smunilla@redhat.com)
  393. - atomic-openshift-installer: Temporarily restrict to single master
  394. (smunilla@redhat.com)
  395. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.12-1
  396. - Sync with the latest image streams (sdodson@redhat.com)
  397. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.11-1
  398. - Migrate xpaas content from pre v1.1.0 (sdodson@redhat.com)
  399. - Import latest xpaas templates and image streams (sdodson@redhat.com)
  400. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.10-1
  401. - Fix update error for templates that didn't previously exist
  402. (jdetiber@redhat.com)
  403. - General cleanup of v3_0_to_v3_1/upgrade.yml (jdetiber@redhat.com)
  404. - Add zabbix pieces to hold AWS S3 bucket stats (jdiaz@redhat.com)
  405. - add ansible dep to vagrant doc (jdetiber@redhat.com)
  406. - oo_filter: don't fail when attribute is not defined (tob@butter.sh)
  407. * Wed Nov 11 2015 Brenton Leanhardt <bleanhar@redhat.com> 3.0.9-1
  408. - Refactor upgrade playbook(s) (jdetiber@redhat.com)
  409. * Tue Nov 10 2015 Scott Dodson <sdodson@redhat.com> 3.0.8-1
  410. - Add origin-clients to uninstall playbook. (abutcher@redhat.com)
  411. - examples: include logging and metrics infrastructure (lmeyer@redhat.com)
  412. - Add separate step to enable services during upgrade. (dgoodwin@redhat.com)
  413. - Update tests now that cli is not asking for rpm/container install
  414. (smunilla@redhat.com)
  415. - atomic-openshift-installer: Remove question for container install
  416. (smunilla@redhat.com)
  417. - Remove references to multi_ec2.py (jdetiber@redhat.com)
  418. - 1279746: Fix leftover disabled features line in config template.
  419. (dgoodwin@redhat.com)
  420. - 1279734: Ensure services are enabled after upgrade. (dgoodwin@redhat.com)
  421. - Fix missing etcd_data_dir bug. (dgoodwin@redhat.com)
  422. - Package the default ansible.cfg with atomic-openshift-utils.
  423. (dgoodwin@redhat.com)
  424. - Add ldap auth identity provider to example inventory. (abutcher@redhat.com)
  425. - Read etcd data dir from appropriate config file. (dgoodwin@redhat.com)
  426. - atomic-openshift-installer: Generate inventory off hosts_to_run_on
  427. (smunilla@redhat.com)
  428. - Various fixes related to connect_to (bleanhar@redhat.com)
  429. - Remove upgrade playbook restriction on 3.0.2. (dgoodwin@redhat.com)
  430. - Conditionals for flannel etcd client certs. (abutcher@redhat.com)
  431. - New `iptablesSyncPeriod` field in node configuration (abutcher@redhat.com)
  432. - Fix indentation on when (jdetiber@redhat.com)
  433. - Bug 1278863 - Error using openshift_pkg_version (jdetiber@redhat.com)
  434. - more cleanup of names (mwoodson@redhat.com)
  435. - Missing conditionals for api/controller sysconfig. (abutcher@redhat.com)
  436. - Updating the atomic-openshift-isntaller local connection logic for the
  437. connect_to addition. (bleanhar@redhat.com)
  438. - cleaned up network checks (mwoodson@redhat.com)
  439. - Minor upgrade improvements. (dgoodwin@redhat.com)
  440. - Wait for cluster to recover after pcs resource restart. (abutcher@redhat.com)
  441. - Bug 1278245 - Failed to add node to existing env using atomic-openshift-
  442. installer (bleanhar@redhat.com)
  443. - remove debug statement (jdetiber@redhat.com)
  444. - Fix removal of kubernetesMasterConfig.apiLevels (jdetiber@redhat.com)
  445. - atomic-openshift-installer: Better specification of ansible connection point
  446. (smunilla@redhat.com)
  447. - Fix issues related to upgrade packages being unavailable
  448. (jdetiber@redhat.com)
  449. - added network checks. also updated item prototype code to support more
  450. (mwoodson@redhat.com)
  451. - Fix data_dir for 3.0 deployments (jdetiber@redhat.com)
  452. - Fix apiLevels modifications (jdetiber@redhat.com)
  453. - Fix creation of origin symlink when dir already exists. (dgoodwin@redhat.com)
  454. - apiLevel changes (jdetiber@redhat.com)
  455. - Write new config to disk after successful upgrade. (dgoodwin@redhat.com)
  456. - Fix pylint errors with getting hosts to run on. (dgoodwin@redhat.com)
  457. - Remove v1beta3 by default for kube_nfs_volumes (jdetiber@redhat.com)
  458. - Add pre-upgrade script to be run on first master. (dgoodwin@redhat.com)
  459. - Start to handle pacemaker ha during upgrade (abutcher@redhat.com)
  460. - Fix lb group related errors (jdetiber@redhat.com)
  461. - Fix file check conditional. (abutcher@redhat.com)
  462. - Don't check for certs in data_dir just raise when they can't be found. Fix
  463. typo. (abutcher@redhat.com)
  464. - exclude atomic-openshift-installer from bin subpackage (tdawson@redhat.com)
  465. - add master_hostnames definition for upgrade (jdetiber@redhat.com)
  466. - Additional upgrade enhancements (jdetiber@redhat.com)
  467. - Handle backups for separate etcd hosts if necessary. (dgoodwin@redhat.com)
  468. - Further upgrade improvements (jdetiber@redhat.com)
  469. - Upgrade improvements (dgoodwin@redhat.com)
  470. - Bug 1278243 - Confusing prompt from atomic-openshift-installer
  471. (bleanhar@redhat.com)
  472. - Bug 1278244 - Previously there was no way to add a node in unattended mode
  473. (bleanhar@redhat.com)
  474. - Revert to defaults (abutcher@redhat.com)
  475. - Bug 1278244 - Incorrect node information gathered by atomic-openshift-
  476. installer (bleanhar@redhat.com)
  477. - atomic-openshift-installer's unattended mode wasn't work with --force for all
  478. cases (bleanhar@redhat.com)
  479. - Making it easier to use pre-release content (bleanhar@redhat.com)
  480. - The uninstall playbook needs to remove /run/openshift-sdn
  481. (bleanhar@redhat.com)
  482. - Various HA changes for pacemaker and native methods. (abutcher@redhat.com)
  483. - Bug 1274201 - Fixing non-root installations if using a local connection
  484. (bleanhar@redhat.com)
  485. - Bug 1274201 - Fixing sudo non-interactive test (bleanhar@redhat.com)
  486. - Bug 1277592 - SDN MTU has hardcoded default (jdetiber@redhat.com)
  487. - Atomic Enterprise/OpenShift Enterprise merge update (jdetiber@redhat.com)
  488. - fix dueling controllers - without controllerLeaseTTL set in config, multiple
  489. controllers will attempt to start (jdetiber@redhat.com)
  490. - default to source persistence for haproxy (jdetiber@redhat.com)
  491. - hardcode openshift binaries for now (jdetiber@redhat.com)
  492. - more tweaks (jdetiber@redhat.com)
  493. - more tweaks (jdetiber@redhat.com)
  494. - additional ha related updates (jdetiber@redhat.com)
  495. - additional native ha changes (abutcher@redhat.com)
  496. - Start of true master ha (jdetiber@redhat.com)
  497. - Atomic Enterprise related changes. (avagarwa@redhat.com)
  498. - Remove pacemaker bits. (abutcher@redhat.com)
  499. - Override hosts deployment_type fact for version we're upgrading to.
  500. (dgoodwin@redhat.com)
  501. - Pylint fixes for config upgrade module. (dgoodwin@redhat.com)
  502. - Disable proxy cert config upgrade until certs being generated.
  503. (dgoodwin@redhat.com)
  504. - remove debug line (florian.lambert@enovance.com)
  505. - [roles/openshift_master_certificates/tasks/main.yml] Fix variable
  506. openshift.master.all_hostnames to openshift.common.all_hostnames
  507. (florian.lambert@enovance.com)
  508. - Fix bug with not upgrading openshift-master to atomic-openshift-master.
  509. (dgoodwin@redhat.com)
  510. - Adding aws and gce packages to ansible-inventory (kwoodson@redhat.com)
  511. - Fix subpackage dependencies (jdetiber@redhat.com)
  512. - Refactor common group evaluation to avoid duplication (jdetiber@redhat.com)
  513. - common/openshift-cluster: Scaleup playbook (smunilla@redhat.com)
  514. - Fix bug from module rename. (dgoodwin@redhat.com)
  515. - Fix bug with default ansible playbook dir. (dgoodwin@redhat.com)
  516. - Use the base package upgrade version so we can check things earlier.
  517. (dgoodwin@redhat.com)
  518. - Skip fail if enterprise deployment type depending on version.
  519. (dgoodwin@redhat.com)
  520. - Add debug output for location of etcd backup. (dgoodwin@redhat.com)
  521. - Filter internal hostnames from the list of parsed names.
  522. (abutcher@redhat.com)
  523. - Move config upgrade to correct place, fix node facts. (dgoodwin@redhat.com)
  524. - Add custom certificates to serving info in master configuration.
  525. (abutcher@redhat.com)
  526. - Add in proxyClientInfo if missing during config upgrade.
  527. (dgoodwin@redhat.com)
  528. - Implement master-config.yaml upgrade for v1beta3 apiLevel removal.
  529. (dgoodwin@redhat.com)
  530. - Fix installer upgrade bug following pylint fix. (dgoodwin@redhat.com)
  531. - Document the new version field for installer config. (dgoodwin@redhat.com)
  532. - Remove my username from some test data. (dgoodwin@redhat.com)
  533. - Add a simple version for the installer config file. (dgoodwin@redhat.com)
  534. - Pylint fix. (dgoodwin@redhat.com)
  535. - Fix issue with master.proxy-client.{crt,key} and omit. (abutcher@redhat.com)
  536. - initial module framework (jdetiber@redhat.com)
  537. - Better info prior to initiating upgrade. (dgoodwin@redhat.com)
  538. - Fix etcd backup bug with not-yet-created /var/lib/origin symlink
  539. (dgoodwin@redhat.com)
  540. - Print info after upgrade completes. (dgoodwin@redhat.com)
  541. - Automatically upgrade legacy config files. (dgoodwin@redhat.com)
  542. - Remove devel fail and let upgrade proceed. (dgoodwin@redhat.com)
  543. - Add utils subpackage missing dep on openshift-ansible-roles.
  544. (dgoodwin@redhat.com)
  545. - Generate timestamped etcd backups. (dgoodwin@redhat.com)
  546. - Add etcd_data_dir fact. (dgoodwin@redhat.com)
  547. - Functional disk space checking for etcd backup. (dgoodwin@redhat.com)
  548. - First cut at checking available disk space for etcd backup.
  549. (dgoodwin@redhat.com)
  550. - Block upgrade if targetting enterprise deployment type. (dgoodwin@redhat.com)
  551. - Change flannel registration default values (sbaubeau@redhat.com)
  552. - Remove empty notify section (sbaubeau@redhat.com)
  553. - Check etcd certs exist for flannel when its support is enabled
  554. (sbaubeau@redhat.com)
  555. - Fix when neither use_openshift_sdn nor use_flannel are specified
  556. (sbaubeau@redhat.com)
  557. - Generate etcd certificats for flannel when is not embedded
  558. (sbaubeau@redhat.com)
  559. - Add missing 2nd true parameters to default Jinja filter (sbaubeau@redhat.com)
  560. - Use 'command' module instead of 'shell' (sbaubeau@redhat.com)
  561. - Add flannel modules documentation (sbaubeau@redhat.com)
  562. - Only remove IPv4 address from docker bridge (sbaubeau@redhat.com)
  563. - Remove multiple use_flannel fact definition (sbaubeau@redhat.com)
  564. - Ensure openshift-sdn and flannel can't be used at the same time
  565. (sbaubeau@redhat.com)
  566. - Add flannel support (sbaubeau@redhat.com)
  567. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  568. - added the %%util in zabbix (mwoodson@redhat.com)
  569. - atomic-openshift-installer: Correct default playbook directory
  570. (smunilla@redhat.com)
  571. - Support for gce (kwoodson@redhat.com)
  572. - fixed a dumb naming mistake (mwoodson@redhat.com)
  573. - added disk tps checks to zabbix (mwoodson@redhat.com)
  574. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  575. - atomic-openshift-installer: Add default openshift-ansible-playbook
  576. (smunilla@redhat.com)
  577. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  578. - ooinstall: Update local install check (smunilla@redhat.com)
  579. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  580. - Moving to Openshift Etcd application (mmahut@redhat.com)
  581. - Add all the possible servicenames to openshift_all_hostnames for masters
  582. (sdodson@redhat.com)
  583. - Adding openshift.node.etcd items (mmahut@redhat.com)
  584. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  585. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  586. - split inventory into subpackages (tdawson@redhat.com)
  587. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  588. warning (mwoodson@redhat.com)
  589. - Rename install_transactions module to openshift_ansible.
  590. (dgoodwin@redhat.com)
  591. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  592. - Add utils subpackage missing dep on openshift-ansible-roles.
  593. (dgoodwin@redhat.com)
  594. - Disable requiretty for only the openshift user (error@ioerror.us)
  595. - Don't require tty to run sudo (error@ioerror.us)
  596. - Attempt to remove the various interfaces left over from an install
  597. (bleanhar@redhat.com)
  598. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  599. - Disable OpenShift features if installing Atomic Enterprise
  600. (jdetiber@redhat.com)
  601. - Use default playbooks if available. (dgoodwin@redhat.com)
  602. - Add uninstall subcommand. (dgoodwin@redhat.com)
  603. - Add subcommands to CLI. (dgoodwin@redhat.com)
  604. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  605. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  606. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  607. dependency (kwoodson@redhat.com)
  608. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  609. (abutcher@redhat.com)
  610. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  611. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  612. - Updating multi_ec2 to support extra_vars and extra_groups
  613. (kwoodson@redhat.com)
  614. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  615. - README_AEP.md: update instructions for creating router and registry
  616. (jlebon@redhat.com)
  617. - README_AEP: Various fixes (walters@verbum.org)
  618. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  619. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  620. - remove debugging pauses (jdetiber@redhat.com)
  621. - make storage plugin dependency installation more flexible
  622. (jdetiber@redhat.com)
  623. - Install storage plugin dependencies (jdetiber@redhat.com)
  624. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  625. - Removing spec files. (kwoodson@redhat.com)
  626. - Updated example (kwoodson@redhat.com)
  627. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  628. (kwoodson@redhat.com)
  629. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  630. (kwoodson@redhat.com)
  631. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  632. (kwoodson@redhat.com)
  633. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  634. (kwoodson@redhat.com)
  635. - Adding tito releasers configuration (bleanhar@redhat.com)
  636. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  637. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  638. (kwoodson@redhat.com)
  639. - Start tracking docker info execution time (jdiaz@redhat.com)
  640. - The uninstall playbook should remove the kubeconfig for non-root installs
  641. (bleanhar@redhat.com)
  642. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  643. - add examples for SDN configuration (jdetiber@redhat.com)
  644. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  645. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  646. - Pylint fixes (abutcher@redhat.com)
  647. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  648. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  649. ansible.spec file (tdawson@redhat.com)
  650. - Fix quotes (spinolacastro@gmail.com)
  651. - Use standard library for version comparison. (abutcher@redhat.com)
  652. - added docker info to the end of docker loop to direct lvm playbook.
  653. (twiest@redhat.com)
  654. - Add missing quotes (spinolacastro@gmail.com)
  655. - Adding Docker Log Options capabilities (epo@jemba.net)
  656. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  657. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  658. - Add proxy client certs to master config. (abutcher@redhat.com)
  659. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  660. - Get default values from openshift_facts (spinolacastro@gmail.com)
  661. - Cleanup (spinolacastro@gmail.com)
  662. - Add missing inventory example (spinolacastro@gmail.com)
  663. - Custom Project Config (spinolacastro@gmail.com)
  664. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  665. - Initial Package