openshift-ansible.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.7
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible
  15. %description
  16. Openshift and Atomic Enterprise Ansible
  17. This repo contains Ansible code and playbooks
  18. for Openshift and Atomic Enterprise.
  19. %prep
  20. %setup -q
  21. %build
  22. # atomic-openshift-utils install
  23. pushd utils
  24. %{__python} setup.py build
  25. popd
  26. %install
  27. # Base openshift-ansible install
  28. mkdir -p %{buildroot}%{_datadir}/%{name}
  29. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  31. # openshift-ansible-bin install
  32. mkdir -p %{buildroot}%{_bindir}
  33. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  34. mkdir -p %{buildroot}/etc/bash_completion.d
  35. mkdir -p %{buildroot}/etc/openshift_ansible
  36. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  37. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  38. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  39. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  40. # Fix links
  41. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  43. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  44. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  45. # openshift-ansible-docs install
  46. # -docs are currently just %doc, no install needed
  47. # openshift-ansible-inventory install
  48. mkdir -p %{buildroot}/etc/ansible
  49. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  52. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  53. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  54. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  55. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  56. # openshift-ansible-playbooks install
  57. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  58. # openshift-ansible-roles install
  59. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  60. # openshift-ansible-filter-plugins install
  61. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  62. # openshift-ansible-lookup-plugins install
  63. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  64. # atomic-openshift-utils install
  65. pushd utils
  66. %{__python} setup.py install --skip-build --root %{buildroot}
  67. # Remove this line once the name change has happened
  68. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  69. popd
  70. # Base openshift-ansible files
  71. %files
  72. %doc LICENSE.md README*
  73. %dir %{_datadir}/ansible/%{name}
  74. # ----------------------------------------------------------------------------------
  75. # openshift-ansible-bin subpackage
  76. # ----------------------------------------------------------------------------------
  77. %package bin
  78. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  79. Requires: %{name}-inventory
  80. Requires: python2
  81. BuildRequires: python2-devel
  82. BuildArch: noarch
  83. %description bin
  84. Scripts to make it nicer when working with hosts that are defined only by metadata.
  85. %files bin
  86. %{_bindir}/*
  87. %{python_sitelib}/openshift_ansible/
  88. /etc/bash_completion.d/*
  89. %config(noreplace) /etc/openshift_ansible/
  90. # ----------------------------------------------------------------------------------
  91. # openshift-ansible-docs subpackage
  92. # ----------------------------------------------------------------------------------
  93. %package docs
  94. Summary: Openshift and Atomic Enterprise Ansible documents
  95. Requires: %{name}
  96. BuildArch: noarch
  97. %description docs
  98. %{summary}.
  99. %files docs
  100. %doc docs
  101. # ----------------------------------------------------------------------------------
  102. # openshift-ansible-inventory subpackage
  103. # ----------------------------------------------------------------------------------
  104. %package inventory
  105. Summary: Openshift and Atomic Enterprise Ansible Inventories
  106. Requires: python2
  107. BuildArch: noarch
  108. %description inventory
  109. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  110. %files inventory
  111. %config(noreplace) /etc/ansible/*
  112. %dir %{_datadir}/ansible/inventory
  113. %{_datadir}/ansible/inventory/multi_inventory.py*
  114. %package inventory-aws
  115. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  116. Requires: %{name}-inventory
  117. Requires: python-boto
  118. BuildArch: noarch
  119. %description inventory-aws
  120. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  121. %files inventory-aws
  122. %{_datadir}/ansible/inventory/aws/ec2.py*
  123. %package inventory-gce
  124. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  125. Requires: %{name}-inventory
  126. Requires: python-libcloud >= 0.13
  127. BuildArch: noarch
  128. %description inventory-gce
  129. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  130. %files inventory-gce
  131. %{_datadir}/ansible/inventory/gce/gce.py*
  132. # ----------------------------------------------------------------------------------
  133. # openshift-ansible-playbooks subpackage
  134. # ----------------------------------------------------------------------------------
  135. %package playbooks
  136. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  137. Requires: %{name}
  138. Requires: %{name}-roles
  139. Requires: %{name}-lookup-plugins
  140. Requires: %{name}-filter-plugins
  141. BuildArch: noarch
  142. %description playbooks
  143. %{summary}.
  144. %files playbooks
  145. %{_datadir}/ansible/%{name}/playbooks
  146. # ----------------------------------------------------------------------------------
  147. # openshift-ansible-roles subpackage
  148. # ----------------------------------------------------------------------------------
  149. %package roles
  150. Summary: Openshift and Atomic Enterprise Ansible roles
  151. Requires: %{name}
  152. Requires: %{name}-lookup-plugins
  153. Requires: %{name}-filter-plugins
  154. BuildArch: noarch
  155. %description roles
  156. %{summary}.
  157. %files roles
  158. %{_datadir}/ansible/%{name}/roles
  159. # ----------------------------------------------------------------------------------
  160. # openshift-ansible-filter-plugins subpackage
  161. # ----------------------------------------------------------------------------------
  162. %package filter-plugins
  163. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  164. Requires: %{name}
  165. BuildArch: noarch
  166. %description filter-plugins
  167. %{summary}.
  168. %files filter-plugins
  169. %{_datadir}/ansible_plugins/filter_plugins
  170. # ----------------------------------------------------------------------------------
  171. # openshift-ansible-lookup-plugins subpackage
  172. # ----------------------------------------------------------------------------------
  173. %package lookup-plugins
  174. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  175. Requires: %{name}
  176. BuildArch: noarch
  177. %description lookup-plugins
  178. %{summary}.
  179. %files lookup-plugins
  180. %{_datadir}/ansible_plugins/lookup_plugins
  181. # ----------------------------------------------------------------------------------
  182. # atomic-openshift-utils subpackage
  183. # ----------------------------------------------------------------------------------
  184. %package -n atomic-openshift-utils
  185. Summary: Atomic OpenShift Utilities
  186. BuildRequires: python-setuptools
  187. Requires: openshift-ansible-playbooks
  188. Requires: openshift-ansible-roles
  189. Requires: ansible
  190. Requires: python-click
  191. Requires: python-setuptools
  192. Requires: PyYAML
  193. BuildArch: noarch
  194. %description -n atomic-openshift-utils
  195. Atomic OpenShift Utilities includes
  196. - atomic-openshift-installer
  197. - other utilities
  198. %files -n atomic-openshift-utils
  199. %{python_sitelib}/ooinstall*
  200. %{_bindir}/atomic-openshift-installer
  201. %changelog
  202. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  203. - added the %%util in zabbix (mwoodson@redhat.com)
  204. - atomic-openshift-installer: Correct default playbook directory
  205. (smunilla@redhat.com)
  206. - Support for gce (kwoodson@redhat.com)
  207. - fixed a dumb naming mistake (mwoodson@redhat.com)
  208. - added disk tps checks to zabbix (mwoodson@redhat.com)
  209. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  210. - atomic-openshift-installer: Add default openshift-ansible-playbook
  211. (smunilla@redhat.com)
  212. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  213. - ooinstall: Update local install check (smunilla@redhat.com)
  214. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  215. - Moving to Openshift Etcd application (mmahut@redhat.com)
  216. - Add all the possible servicenames to openshift_all_hostnames for masters
  217. (sdodson@redhat.com)
  218. - Adding openshift.node.etcd items (mmahut@redhat.com)
  219. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  220. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  221. - split inventory into subpackages (tdawson@redhat.com)
  222. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  223. warning (mwoodson@redhat.com)
  224. - Rename install_transactions module to openshift_ansible.
  225. (dgoodwin@redhat.com)
  226. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  227. - Add utils subpackage missing dep on openshift-ansible-roles.
  228. (dgoodwin@redhat.com)
  229. - Disable requiretty for only the openshift user (error@ioerror.us)
  230. - Don't require tty to run sudo (error@ioerror.us)
  231. - Attempt to remove the various interfaces left over from an install
  232. (bleanhar@redhat.com)
  233. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  234. - Disable OpenShift features if installing Atomic Enterprise
  235. (jdetiber@redhat.com)
  236. - Use default playbooks if available. (dgoodwin@redhat.com)
  237. - Add uninstall subcommand. (dgoodwin@redhat.com)
  238. - Add subcommands to CLI. (dgoodwin@redhat.com)
  239. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  240. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  241. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  242. dependency (kwoodson@redhat.com)
  243. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  244. (abutcher@redhat.com)
  245. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  246. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  247. - Updating multi_ec2 to support extra_vars and extra_groups
  248. (kwoodson@redhat.com)
  249. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  250. - README_AEP.md: update instructions for creating router and registry
  251. (jlebon@redhat.com)
  252. - README_AEP: Various fixes (walters@verbum.org)
  253. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  254. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  255. - remove debugging pauses (jdetiber@redhat.com)
  256. - make storage plugin dependency installation more flexible
  257. (jdetiber@redhat.com)
  258. - Install storage plugin dependencies (jdetiber@redhat.com)
  259. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  260. - Removing spec files. (kwoodson@redhat.com)
  261. - Updated example (kwoodson@redhat.com)
  262. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  263. (kwoodson@redhat.com)
  264. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  265. (kwoodson@redhat.com)
  266. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  267. (kwoodson@redhat.com)
  268. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  269. (kwoodson@redhat.com)
  270. - Adding tito releasers configuration (bleanhar@redhat.com)
  271. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  272. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  273. (kwoodson@redhat.com)
  274. - Start tracking docker info execution time (jdiaz@redhat.com)
  275. - The uninstall playbook should remove the kubeconfig for non-root installs
  276. (bleanhar@redhat.com)
  277. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  278. - add examples for SDN configuration (jdetiber@redhat.com)
  279. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  280. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  281. - Pylint fixes (abutcher@redhat.com)
  282. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  283. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  284. ansible.spec file (tdawson@redhat.com)
  285. - Fix quotes (spinolacastro@gmail.com)
  286. - Use standard library for version comparison. (abutcher@redhat.com)
  287. - added docker info to the end of docker loop to direct lvm playbook.
  288. (twiest@redhat.com)
  289. - Add missing quotes (spinolacastro@gmail.com)
  290. - Adding Docker Log Options capabilities (epo@jemba.net)
  291. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  292. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  293. - Add proxy client certs to master config. (abutcher@redhat.com)
  294. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  295. - Get default values from openshift_facts (spinolacastro@gmail.com)
  296. - Cleanup (spinolacastro@gmail.com)
  297. - Add missing inventory example (spinolacastro@gmail.com)
  298. - Custom Project Config (spinolacastro@gmail.com)
  299. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  300. - Initial Package