openshift-ansible.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524
  1. # %commit is intended to be set by tito custom builders provided
  2. # in the .tito/lib directory. The values in this spec file will not be kept up to date.
  3. %{!?commit:
  4. %global commit c64d09e528ca433832c6b6e6f5c7734a9cc8ee6f
  5. }
  6. Name: openshift-ansible
  7. Version: 3.0.8
  8. Release: 1%{?dist}
  9. Summary: Openshift and Atomic Enterprise Ansible
  10. License: ASL 2.0
  11. URL: https://github.com/openshift/openshift-ansible
  12. Source0: https://github.com/openshift/openshift-ansible/archive/%{commit}/%{name}-%{version}.tar.gz
  13. BuildArch: noarch
  14. Requires: ansible
  15. %description
  16. Openshift and Atomic Enterprise Ansible
  17. This repo contains Ansible code and playbooks
  18. for Openshift and Atomic Enterprise.
  19. %prep
  20. %setup -q
  21. %build
  22. # atomic-openshift-utils install
  23. pushd utils
  24. %{__python} setup.py build
  25. popd
  26. %install
  27. # Base openshift-ansible install
  28. mkdir -p %{buildroot}%{_datadir}/%{name}
  29. mkdir -p %{buildroot}%{_datadir}/ansible/%{name}
  30. mkdir -p %{buildroot}%{_datadir}/ansible_plugins
  31. # openshift-ansible-bin install
  32. mkdir -p %{buildroot}%{_bindir}
  33. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  34. mkdir -p %{buildroot}/etc/bash_completion.d
  35. mkdir -p %{buildroot}/etc/openshift_ansible
  36. cp -p bin/{ossh,oscp,opssh,opscp,ohi} %{buildroot}%{_bindir}
  37. cp -pP bin/openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  38. cp -p bin/ossh_bash_completion %{buildroot}/etc/bash_completion.d
  39. cp -p bin/openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  40. # Fix links
  41. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  42. rm -f %{buildroot}%{python_sitelib}/openshift_ansible/aws
  43. ln -sf %{_datadir}/ansible/inventory/multi_inventory.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_inventory.py
  44. ln -sf %{_datadir}/ansible/inventory/aws %{buildroot}%{python_sitelib}/openshift_ansible/aws
  45. # openshift-ansible-docs install
  46. # -docs are currently just %doc, no install needed
  47. # openshift-ansible-inventory install
  48. mkdir -p %{buildroot}/etc/ansible
  49. mkdir -p %{buildroot}%{_datadir}/ansible/inventory
  50. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/aws
  51. mkdir -p %{buildroot}%{_datadir}/ansible/inventory/gce
  52. cp -p inventory/multi_inventory.py %{buildroot}%{_datadir}/ansible/inventory
  53. cp -p inventory/multi_inventory.yaml.example %{buildroot}/etc/ansible/multi_inventory.yaml
  54. cp -p inventory/aws/hosts/ec2.py %{buildroot}%{_datadir}/ansible/inventory/aws
  55. cp -p inventory/gce/hosts/gce.py %{buildroot}%{_datadir}/ansible/inventory/gce
  56. # openshift-ansible-playbooks install
  57. cp -rp playbooks %{buildroot}%{_datadir}/ansible/%{name}/
  58. # openshift-ansible-roles install
  59. cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
  60. # openshift-ansible-filter-plugins install
  61. cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
  62. # openshift-ansible-lookup-plugins install
  63. cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
  64. # atomic-openshift-utils install
  65. pushd utils
  66. %{__python} setup.py install --skip-build --root %{buildroot}
  67. # Remove this line once the name change has happened
  68. mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
  69. mkdir -p %{buildroot}%{_datadir}/atomic-openshift-utils/
  70. cp etc/ansible.cfg %{buildroot}%{_datadir}/atomic-openshift-utils/ansible.cfg
  71. popd
  72. # Base openshift-ansible files
  73. %files
  74. %doc LICENSE.md README*
  75. %dir %{_datadir}/ansible/%{name}
  76. # ----------------------------------------------------------------------------------
  77. # openshift-ansible-bin subpackage
  78. # ----------------------------------------------------------------------------------
  79. %package bin
  80. Summary: Openshift and Atomic Enterprise Ansible Scripts for working with metadata hosts
  81. Requires: %{name}-inventory
  82. Requires: python2
  83. BuildRequires: python2-devel
  84. BuildArch: noarch
  85. %description bin
  86. Scripts to make it nicer when working with hosts that are defined only by metadata.
  87. %files bin
  88. %{_bindir}/*
  89. %exclude %{_bindir}/atomic-openshift-installer
  90. %{python_sitelib}/openshift_ansible/
  91. /etc/bash_completion.d/*
  92. %config(noreplace) /etc/openshift_ansible/
  93. # ----------------------------------------------------------------------------------
  94. # openshift-ansible-docs subpackage
  95. # ----------------------------------------------------------------------------------
  96. %package docs
  97. Summary: Openshift and Atomic Enterprise Ansible documents
  98. Requires: %{name}
  99. BuildArch: noarch
  100. %description docs
  101. %{summary}.
  102. %files docs
  103. %doc docs
  104. # ----------------------------------------------------------------------------------
  105. # openshift-ansible-inventory subpackage
  106. # ----------------------------------------------------------------------------------
  107. %package inventory
  108. Summary: Openshift and Atomic Enterprise Ansible Inventories
  109. Requires: python2
  110. BuildArch: noarch
  111. %description inventory
  112. Ansible Inventories used with the openshift-ansible scripts and playbooks.
  113. %files inventory
  114. %config(noreplace) /etc/ansible/*
  115. %dir %{_datadir}/ansible/inventory
  116. %{_datadir}/ansible/inventory/multi_inventory.py*
  117. %package inventory-aws
  118. Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
  119. Requires: %{name}-inventory
  120. Requires: python-boto
  121. BuildArch: noarch
  122. %description inventory-aws
  123. Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
  124. %files inventory-aws
  125. %{_datadir}/ansible/inventory/aws/ec2.py*
  126. %package inventory-gce
  127. Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
  128. Requires: %{name}-inventory
  129. Requires: python-libcloud >= 0.13
  130. BuildArch: noarch
  131. %description inventory-gce
  132. Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
  133. %files inventory-gce
  134. %{_datadir}/ansible/inventory/gce/gce.py*
  135. # ----------------------------------------------------------------------------------
  136. # openshift-ansible-playbooks subpackage
  137. # ----------------------------------------------------------------------------------
  138. %package playbooks
  139. Summary: Openshift and Atomic Enterprise Ansible Playbooks
  140. Requires: %{name}
  141. Requires: %{name}-roles
  142. Requires: %{name}-lookup-plugins
  143. Requires: %{name}-filter-plugins
  144. BuildArch: noarch
  145. %description playbooks
  146. %{summary}.
  147. %files playbooks
  148. %{_datadir}/ansible/%{name}/playbooks
  149. # ----------------------------------------------------------------------------------
  150. # openshift-ansible-roles subpackage
  151. # ----------------------------------------------------------------------------------
  152. %package roles
  153. Summary: Openshift and Atomic Enterprise Ansible roles
  154. Requires: %{name}
  155. Requires: %{name}-lookup-plugins
  156. Requires: %{name}-filter-plugins
  157. BuildArch: noarch
  158. %description roles
  159. %{summary}.
  160. %files roles
  161. %{_datadir}/ansible/%{name}/roles
  162. # ----------------------------------------------------------------------------------
  163. # openshift-ansible-filter-plugins subpackage
  164. # ----------------------------------------------------------------------------------
  165. %package filter-plugins
  166. Summary: Openshift and Atomic Enterprise Ansible filter plugins
  167. Requires: %{name}
  168. BuildArch: noarch
  169. %description filter-plugins
  170. %{summary}.
  171. %files filter-plugins
  172. %{_datadir}/ansible_plugins/filter_plugins
  173. # ----------------------------------------------------------------------------------
  174. # openshift-ansible-lookup-plugins subpackage
  175. # ----------------------------------------------------------------------------------
  176. %package lookup-plugins
  177. Summary: Openshift and Atomic Enterprise Ansible lookup plugins
  178. Requires: %{name}
  179. BuildArch: noarch
  180. %description lookup-plugins
  181. %{summary}.
  182. %files lookup-plugins
  183. %{_datadir}/ansible_plugins/lookup_plugins
  184. # ----------------------------------------------------------------------------------
  185. # atomic-openshift-utils subpackage
  186. # ----------------------------------------------------------------------------------
  187. %package -n atomic-openshift-utils
  188. Summary: Atomic OpenShift Utilities
  189. BuildRequires: python-setuptools
  190. Requires: openshift-ansible-playbooks
  191. Requires: openshift-ansible-roles
  192. Requires: ansible
  193. Requires: python-click
  194. Requires: python-setuptools
  195. Requires: PyYAML
  196. BuildArch: noarch
  197. %description -n atomic-openshift-utils
  198. Atomic OpenShift Utilities includes
  199. - atomic-openshift-installer
  200. - other utilities
  201. %files -n atomic-openshift-utils
  202. %{python_sitelib}/ooinstall*
  203. %{_bindir}/atomic-openshift-installer
  204. %{_datadir}/atomic-openshift-utils/ansible.cfg
  205. %changelog
  206. * Tue Nov 10 2015 Scott Dodson <sdodson@redhat.com> 3.0.8-1
  207. - Add origin-clients to uninstall playbook. (abutcher@redhat.com)
  208. - examples: include logging and metrics infrastructure (lmeyer@redhat.com)
  209. - Add separate step to enable services during upgrade. (dgoodwin@redhat.com)
  210. - Update tests now that cli is not asking for rpm/container install
  211. (smunilla@redhat.com)
  212. - atomic-openshift-installer: Remove question for container install
  213. (smunilla@redhat.com)
  214. - Remove references to multi_ec2.py (jdetiber@redhat.com)
  215. - 1279746: Fix leftover disabled features line in config template.
  216. (dgoodwin@redhat.com)
  217. - 1279734: Ensure services are enabled after upgrade. (dgoodwin@redhat.com)
  218. - Fix missing etcd_data_dir bug. (dgoodwin@redhat.com)
  219. - Package the default ansible.cfg with atomic-openshift-utils.
  220. (dgoodwin@redhat.com)
  221. - Add ldap auth identity provider to example inventory. (abutcher@redhat.com)
  222. - Read etcd data dir from appropriate config file. (dgoodwin@redhat.com)
  223. - atomic-openshift-installer: Generate inventory off hosts_to_run_on
  224. (smunilla@redhat.com)
  225. - Various fixes related to connect_to (bleanhar@redhat.com)
  226. - Remove upgrade playbook restriction on 3.0.2. (dgoodwin@redhat.com)
  227. - Conditionals for flannel etcd client certs. (abutcher@redhat.com)
  228. - New `iptablesSyncPeriod` field in node configuration (abutcher@redhat.com)
  229. - Fix indentation on when (jdetiber@redhat.com)
  230. - Bug 1278863 - Error using openshift_pkg_version (jdetiber@redhat.com)
  231. - more cleanup of names (mwoodson@redhat.com)
  232. - Missing conditionals for api/controller sysconfig. (abutcher@redhat.com)
  233. - Updating the atomic-openshift-isntaller local connection logic for the
  234. connect_to addition. (bleanhar@redhat.com)
  235. - cleaned up network checks (mwoodson@redhat.com)
  236. - Minor upgrade improvements. (dgoodwin@redhat.com)
  237. - Wait for cluster to recover after pcs resource restart. (abutcher@redhat.com)
  238. - Bug 1278245 - Failed to add node to existing env using atomic-openshift-
  239. installer (bleanhar@redhat.com)
  240. - remove debug statement (jdetiber@redhat.com)
  241. - Fix removal of kubernetesMasterConfig.apiLevels (jdetiber@redhat.com)
  242. - atomic-openshift-installer: Better specification of ansible connection point
  243. (smunilla@redhat.com)
  244. - Fix issues related to upgrade packages being unavailable
  245. (jdetiber@redhat.com)
  246. - added network checks. also updated item prototype code to support more
  247. (mwoodson@redhat.com)
  248. - Fix data_dir for 3.0 deployments (jdetiber@redhat.com)
  249. - Fix apiLevels modifications (jdetiber@redhat.com)
  250. - Fix creation of origin symlink when dir already exists. (dgoodwin@redhat.com)
  251. - apiLevel changes (jdetiber@redhat.com)
  252. - Write new config to disk after successful upgrade. (dgoodwin@redhat.com)
  253. - Fix pylint errors with getting hosts to run on. (dgoodwin@redhat.com)
  254. - Remove v1beta3 by default for kube_nfs_volumes (jdetiber@redhat.com)
  255. - Add pre-upgrade script to be run on first master. (dgoodwin@redhat.com)
  256. - Start to handle pacemaker ha during upgrade (abutcher@redhat.com)
  257. - Fix lb group related errors (jdetiber@redhat.com)
  258. - Fix file check conditional. (abutcher@redhat.com)
  259. - Don't check for certs in data_dir just raise when they can't be found. Fix
  260. typo. (abutcher@redhat.com)
  261. - exclude atomic-openshift-installer from bin subpackage (tdawson@redhat.com)
  262. - add master_hostnames definition for upgrade (jdetiber@redhat.com)
  263. - Additional upgrade enhancements (jdetiber@redhat.com)
  264. - Handle backups for separate etcd hosts if necessary. (dgoodwin@redhat.com)
  265. - Further upgrade improvements (jdetiber@redhat.com)
  266. - Upgrade improvements (dgoodwin@redhat.com)
  267. - Bug 1278243 - Confusing prompt from atomic-openshift-installer
  268. (bleanhar@redhat.com)
  269. - Bug 1278244 - Previously there was no way to add a node in unattended mode
  270. (bleanhar@redhat.com)
  271. - Revert to defaults (abutcher@redhat.com)
  272. - Bug 1278244 - Incorrect node information gathered by atomic-openshift-
  273. installer (bleanhar@redhat.com)
  274. - atomic-openshift-installer's unattended mode wasn't work with --force for all
  275. cases (bleanhar@redhat.com)
  276. - Making it easier to use pre-release content (bleanhar@redhat.com)
  277. - The uninstall playbook needs to remove /run/openshift-sdn
  278. (bleanhar@redhat.com)
  279. - Various HA changes for pacemaker and native methods. (abutcher@redhat.com)
  280. - Bug 1274201 - Fixing non-root installations if using a local connection
  281. (bleanhar@redhat.com)
  282. - Bug 1274201 - Fixing sudo non-interactive test (bleanhar@redhat.com)
  283. - Bug 1277592 - SDN MTU has hardcoded default (jdetiber@redhat.com)
  284. - Atomic Enterprise/OpenShift Enterprise merge update (jdetiber@redhat.com)
  285. - fix dueling controllers - without controllerLeaseTTL set in config, multiple
  286. controllers will attempt to start (jdetiber@redhat.com)
  287. - default to source persistence for haproxy (jdetiber@redhat.com)
  288. - hardcode openshift binaries for now (jdetiber@redhat.com)
  289. - more tweaks (jdetiber@redhat.com)
  290. - more tweaks (jdetiber@redhat.com)
  291. - additional ha related updates (jdetiber@redhat.com)
  292. - additional native ha changes (abutcher@redhat.com)
  293. - Start of true master ha (jdetiber@redhat.com)
  294. - Atomic Enterprise related changes. (avagarwa@redhat.com)
  295. - Remove pacemaker bits. (abutcher@redhat.com)
  296. - Override hosts deployment_type fact for version we're upgrading to.
  297. (dgoodwin@redhat.com)
  298. - Pylint fixes for config upgrade module. (dgoodwin@redhat.com)
  299. - Disable proxy cert config upgrade until certs being generated.
  300. (dgoodwin@redhat.com)
  301. - remove debug line (florian.lambert@enovance.com)
  302. - [roles/openshift_master_certificates/tasks/main.yml] Fix variable
  303. openshift.master.all_hostnames to openshift.common.all_hostnames
  304. (florian.lambert@enovance.com)
  305. - Fix bug with not upgrading openshift-master to atomic-openshift-master.
  306. (dgoodwin@redhat.com)
  307. - Adding aws and gce packages to ansible-inventory (kwoodson@redhat.com)
  308. - Fix subpackage dependencies (jdetiber@redhat.com)
  309. - Refactor common group evaluation to avoid duplication (jdetiber@redhat.com)
  310. - common/openshift-cluster: Scaleup playbook (smunilla@redhat.com)
  311. - Fix bug from module rename. (dgoodwin@redhat.com)
  312. - Fix bug with default ansible playbook dir. (dgoodwin@redhat.com)
  313. - Use the base package upgrade version so we can check things earlier.
  314. (dgoodwin@redhat.com)
  315. - Skip fail if enterprise deployment type depending on version.
  316. (dgoodwin@redhat.com)
  317. - Add debug output for location of etcd backup. (dgoodwin@redhat.com)
  318. - Filter internal hostnames from the list of parsed names.
  319. (abutcher@redhat.com)
  320. - Move config upgrade to correct place, fix node facts. (dgoodwin@redhat.com)
  321. - Add custom certificates to serving info in master configuration.
  322. (abutcher@redhat.com)
  323. - Add in proxyClientInfo if missing during config upgrade.
  324. (dgoodwin@redhat.com)
  325. - Implement master-config.yaml upgrade for v1beta3 apiLevel removal.
  326. (dgoodwin@redhat.com)
  327. - Fix installer upgrade bug following pylint fix. (dgoodwin@redhat.com)
  328. - Document the new version field for installer config. (dgoodwin@redhat.com)
  329. - Remove my username from some test data. (dgoodwin@redhat.com)
  330. - Add a simple version for the installer config file. (dgoodwin@redhat.com)
  331. - Pylint fix. (dgoodwin@redhat.com)
  332. - Fix issue with master.proxy-client.{crt,key} and omit. (abutcher@redhat.com)
  333. - initial module framework (jdetiber@redhat.com)
  334. - Better info prior to initiating upgrade. (dgoodwin@redhat.com)
  335. - Fix etcd backup bug with not-yet-created /var/lib/origin symlink
  336. (dgoodwin@redhat.com)
  337. - Print info after upgrade completes. (dgoodwin@redhat.com)
  338. - Automatically upgrade legacy config files. (dgoodwin@redhat.com)
  339. - Remove devel fail and let upgrade proceed. (dgoodwin@redhat.com)
  340. - Add utils subpackage missing dep on openshift-ansible-roles.
  341. (dgoodwin@redhat.com)
  342. - Generate timestamped etcd backups. (dgoodwin@redhat.com)
  343. - Add etcd_data_dir fact. (dgoodwin@redhat.com)
  344. - Functional disk space checking for etcd backup. (dgoodwin@redhat.com)
  345. - First cut at checking available disk space for etcd backup.
  346. (dgoodwin@redhat.com)
  347. - Block upgrade if targetting enterprise deployment type. (dgoodwin@redhat.com)
  348. - Change flannel registration default values (sbaubeau@redhat.com)
  349. - Remove empty notify section (sbaubeau@redhat.com)
  350. - Check etcd certs exist for flannel when its support is enabled
  351. (sbaubeau@redhat.com)
  352. - Fix when neither use_openshift_sdn nor use_flannel are specified
  353. (sbaubeau@redhat.com)
  354. - Generate etcd certificats for flannel when is not embedded
  355. (sbaubeau@redhat.com)
  356. - Add missing 2nd true parameters to default Jinja filter (sbaubeau@redhat.com)
  357. - Use 'command' module instead of 'shell' (sbaubeau@redhat.com)
  358. - Add flannel modules documentation (sbaubeau@redhat.com)
  359. - Only remove IPv4 address from docker bridge (sbaubeau@redhat.com)
  360. - Remove multiple use_flannel fact definition (sbaubeau@redhat.com)
  361. - Ensure openshift-sdn and flannel can't be used at the same time
  362. (sbaubeau@redhat.com)
  363. - Add flannel support (sbaubeau@redhat.com)
  364. * Wed Nov 04 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.7-1
  365. - added the %%util in zabbix (mwoodson@redhat.com)
  366. - atomic-openshift-installer: Correct default playbook directory
  367. (smunilla@redhat.com)
  368. - Support for gce (kwoodson@redhat.com)
  369. - fixed a dumb naming mistake (mwoodson@redhat.com)
  370. - added disk tps checks to zabbix (mwoodson@redhat.com)
  371. - atomic-openshift-installer: Correct inaccurate prompt (smunilla@redhat.com)
  372. - atomic-openshift-installer: Add default openshift-ansible-playbook
  373. (smunilla@redhat.com)
  374. - ooinstall: Add check for nopwd sudo (smunilla@redhat.com)
  375. - ooinstall: Update local install check (smunilla@redhat.com)
  376. - oo-install: Support running on the host to be deployed (smunilla@redhat.com)
  377. - Moving to Openshift Etcd application (mmahut@redhat.com)
  378. - Add all the possible servicenames to openshift_all_hostnames for masters
  379. (sdodson@redhat.com)
  380. - Adding openshift.node.etcd items (mmahut@redhat.com)
  381. - Fix etcd cert generation when etcd_interface is defined (jdetiber@redhat.com)
  382. - get zabbix ready to start tracking status of pcp (jdiaz@redhat.com)
  383. - split inventory into subpackages (tdawson@redhat.com)
  384. - changed the cpu alert to only alert if cpu idle more than 5x. Change alert to
  385. warning (mwoodson@redhat.com)
  386. - Rename install_transactions module to openshift_ansible.
  387. (dgoodwin@redhat.com)
  388. - atomic-openshift-installer: Text improvements (smunilla@redhat.com)
  389. - Add utils subpackage missing dep on openshift-ansible-roles.
  390. (dgoodwin@redhat.com)
  391. - Disable requiretty for only the openshift user (error@ioerror.us)
  392. - Don't require tty to run sudo (error@ioerror.us)
  393. - Attempt to remove the various interfaces left over from an install
  394. (bleanhar@redhat.com)
  395. - Pulling latest gce.py module from ansible (kwoodson@redhat.com)
  396. - Disable OpenShift features if installing Atomic Enterprise
  397. (jdetiber@redhat.com)
  398. - Use default playbooks if available. (dgoodwin@redhat.com)
  399. - Add uninstall subcommand. (dgoodwin@redhat.com)
  400. - Add subcommands to CLI. (dgoodwin@redhat.com)
  401. - Remove images options in oadm command (nakayamakenjiro@gmail.com)
  402. * Fri Oct 30 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.6-1
  403. - Adding python-boto and python-libcloud to openshift-ansible-inventory
  404. dependency (kwoodson@redhat.com)
  405. - Use more specific enterprise version for version_greater_than_3_1_or_1_1.
  406. (abutcher@redhat.com)
  407. - Conditionalizing the support for the v1beta3 api (bleanhar@redhat.com)
  408. * Thu Oct 29 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.5-1
  409. - Updating multi_ec2 to support extra_vars and extra_groups
  410. (kwoodson@redhat.com)
  411. - Removing the template and doing to_nice_yaml instead (kwoodson@redhat.com)
  412. - README_AEP.md: update instructions for creating router and registry
  413. (jlebon@redhat.com)
  414. - README_AEP: Various fixes (walters@verbum.org)
  415. - Fixing for extra_vars rename. (kwoodson@redhat.com)
  416. - make storage_plugin_deps conditional on deployment_type (jdetiber@redhat.com)
  417. - remove debugging pauses (jdetiber@redhat.com)
  418. - make storage plugin dependency installation more flexible
  419. (jdetiber@redhat.com)
  420. - Install storage plugin dependencies (jdetiber@redhat.com)
  421. * Wed Oct 28 2015 Kenny Woodson <kwoodson@redhat.com> 3.0.4-1
  422. - Removing spec files. (kwoodson@redhat.com)
  423. - Updated example (kwoodson@redhat.com)
  424. - Automatic commit of package [openshift-ansible-inventory] release [0.0.11-1].
  425. (kwoodson@redhat.com)
  426. - Automatic commit of package [openshift-ansible-bin] release [0.0.21-1].
  427. (kwoodson@redhat.com)
  428. - Automatic commit of package [openshift-ansible-inventory] release [0.0.10-1].
  429. (kwoodson@redhat.com)
  430. - Automatic commit of package [openshift-ansible-bin] release [0.0.20-1].
  431. (kwoodson@redhat.com)
  432. - Adding tito releasers configuration (bleanhar@redhat.com)
  433. - Bug fixes for the uninstall playbook (bleanhar@redhat.com)
  434. - Adding clone vars and groups. Renamed hostvars to extra_vars.
  435. (kwoodson@redhat.com)
  436. - Start tracking docker info execution time (jdiaz@redhat.com)
  437. - The uninstall playbook should remove the kubeconfig for non-root installs
  438. (bleanhar@redhat.com)
  439. - Adding uninstall support for Atomic Host (bleanhar@redhat.com)
  440. - add examples for SDN configuration (jdetiber@redhat.com)
  441. * Tue Oct 27 2015 Troy Dawson <tdawson@redhat.com> 3.0.3-1
  442. - Pylint fixes and ignores for incoming oo-install code. (dgoodwin@redhat.com)
  443. - Pylint fixes (abutcher@redhat.com)
  444. - Adding zabbix type and fixing zabbix agent vars (kwoodson@redhat.com)
  445. - Add atomic-openshift-utils add atomic-openshift-utils to openshift-
  446. ansible.spec file (tdawson@redhat.com)
  447. - Fix quotes (spinolacastro@gmail.com)
  448. - Use standard library for version comparison. (abutcher@redhat.com)
  449. - added docker info to the end of docker loop to direct lvm playbook.
  450. (twiest@redhat.com)
  451. - Add missing quotes (spinolacastro@gmail.com)
  452. - Adding Docker Log Options capabilities (epo@jemba.net)
  453. - Move version greater_than_fact into openshift_facts (abutcher@redhat.com)
  454. - Don't include proxy client cert when <3.1 or <1.1 (abutcher@redhat.com)
  455. - Add proxy client certs to master config. (abutcher@redhat.com)
  456. - Update imagestreams and quickstarts from origin (sdodson@redhat.com)
  457. - Get default values from openshift_facts (spinolacastro@gmail.com)
  458. - Cleanup (spinolacastro@gmail.com)
  459. - Add missing inventory example (spinolacastro@gmail.com)
  460. - Custom Project Config (spinolacastro@gmail.com)
  461. * Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1
  462. - Initial Package