openshift-ansible-bin.spec 3.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. Summary: OpenShift Ansible Scripts for working with metadata hosts
  2. Name: openshift-ansible-bin
  3. Version: 0.0.17
  4. Release: 1%{?dist}
  5. License: ASL 2.0
  6. URL: https://github.com/openshift/openshift-ansible
  7. Source0: %{name}-%{version}.tar.gz
  8. Requires: python2, openshift-ansible-inventory
  9. BuildRequires: python2-devel
  10. BuildArch: noarch
  11. %description
  12. Scripts to make it nicer when working with hosts that are defined only by metadata.
  13. %prep
  14. %setup -q
  15. %build
  16. %install
  17. mkdir -p %{buildroot}%{_bindir}
  18. mkdir -p %{buildroot}%{python_sitelib}/openshift_ansible
  19. mkdir -p %{buildroot}/etc/bash_completion.d
  20. mkdir -p %{buildroot}/etc/openshift_ansible
  21. cp -p ossh oscp opssh opscp ohi %{buildroot}%{_bindir}
  22. cp -pP openshift_ansible/* %{buildroot}%{python_sitelib}/openshift_ansible
  23. # Make it so we can load multi_ec2.py as a library.
  24. rm %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.py*
  25. ln -sf /usr/share/ansible/inventory/multi_ec2.py %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.py
  26. ln -sf /usr/share/ansible/inventory/multi_ec2.pyc %{buildroot}%{python_sitelib}/openshift_ansible/multi_ec2.pyc
  27. cp -p ossh_bash_completion %{buildroot}/etc/bash_completion.d
  28. cp -p openshift_ansible.conf.example %{buildroot}/etc/openshift_ansible/openshift_ansible.conf
  29. %files
  30. %{_bindir}/*
  31. %{python_sitelib}/openshift_ansible/
  32. /etc/bash_completion.d/*
  33. %config(noreplace) /etc/openshift_ansible/
  34. %changelog
  35. * Fri May 15 2015 Thomas Wiest <twiest@redhat.com> 0.0.17-1
  36. - fixed the openshift-ansible-bin build (twiest@redhat.com)
  37. * Fri May 15 2015 Thomas Wiest <twiest@redhat.com> 0.0.14-1
  38. - Command line tools import multi_ec2 as lib (kwoodson@redhat.com)
  39. - Adding cache location for multi ec2 (kwoodson@redhat.com)
  40. * Thu May 07 2015 Thomas Wiest <twiest@redhat.com> 0.0.13-1
  41. - added '-e all' to ohi and fixed pylint errors. (twiest@redhat.com)
  42. * Tue May 05 2015 Thomas Wiest <twiest@redhat.com> 0.0.12-1
  43. - fixed opssh and opscp to allow just environment or just host-type.
  44. (twiest@redhat.com)
  45. * Mon May 04 2015 Thomas Wiest <twiest@redhat.com> 0.0.11-1
  46. - changed opssh to a bash script using ohi to make it easier to maintain, and
  47. to expose all of the pssh features directly. (twiest@redhat.com)
  48. - Added --user option to ohi to pre-pend the username in the hostlist output.
  49. (twiest@redhat.com)
  50. - Added utils.py that contains a normalize_dnsname function good for sorting
  51. dns names to a human readable list. (twiest@redhat.com)
  52. * Thu Apr 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.10-1
  53. - added --list-host-types option to opscp (twiest@redhat.com)
  54. * Thu Apr 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.9-1
  55. - added opscp (twiest@redhat.com)
  56. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.8-1
  57. - fixed bug in opssh where it wouldn't actually run pssh (twiest@redhat.com)
  58. * Mon Apr 13 2015 Thomas Wiest <twiest@redhat.com> 0.0.7-1
  59. - added the ability to run opssh and ohi on all hosts in an environment, as
  60. well as all hosts of the same host-type regardless of environment
  61. (twiest@redhat.com)
  62. - added ohi (twiest@redhat.com)
  63. * Thu Apr 09 2015 Thomas Wiest <twiest@redhat.com> 0.0.6-1
  64. - fixed bug where opssh would throw an exception if pssh returned a non-zero
  65. exit code (twiest@redhat.com)
  66. * Wed Apr 08 2015 Thomas Wiest <twiest@redhat.com> 0.0.5-1
  67. - fixed the opssh default output behavior to be consistent with pssh. Also
  68. fixed a bug in how directories are named for --outdir and --errdir.
  69. (twiest@redhat.com)
  70. * Tue Mar 31 2015 Thomas Wiest <twiest@redhat.com> 0.0.4-1
  71. - Fixed when tag was missing and added opssh completion (kwoodson@redhat.com)
  72. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.3-1
  73. - created a python package named openshift_ansible (twiest@redhat.com)
  74. * Mon Mar 30 2015 Thomas Wiest <twiest@redhat.com> 0.0.2-1
  75. - added config file support to opssh, ossh, and oscp (twiest@redhat.com)
  76. * Tue Mar 24 2015 Thomas Wiest <twiest@redhat.com> 0.0.1-1
  77. - new package built with tito